I ran post-review in debug mode

"post-review  --server=http://bzr.example.com 

I got this error message

>>> RBTools 0.4.3
>>> Python 2.7.3 (default, Apr 10 2012, 23:24:47) [MSC v.1500 64 bit 
>>> Running on Windows-7-6.1.7600
>>> Home = C:\Users\username\AppData\Roaming
>>> Current Directory = C:\code\path\projectname\trunk
>>> Checking the repository type. Errors shown below are mostly harmless.
DEBUG:root:Checking for a Bazaar repository...
DEBUG:root:Running: bzr info
DEBUG:root:repository info: Path: C:\code\path\projectname\trunk, Base 
path: /, Supports changesets: False
>>> Finished checking the repository type.
>>> HTTP GETting api/info/
DEBUG:root:Running: bzr diff -q -r submit:..
DEBUG:root:Command exited with rc 3: ['bzr', 'diff', '-q', '-r', 
bzr: ERROR: No submit branch available for branch 
>>> HTTP GETting api/
>>> HTTP GETting http://bzr.example.com/api/info/
>>> Using the new web API
>>> Attempting to create review request on 
bzr+ssh://usern...@bzr.example.com/bzr/path/projectname/trunk/ for None
>>> HTTP POSTing to http://bzr.example.com/api/review-requests/: 
>>> Review request created
>>> Uploading diff, size: 78
>>> HTTP POSTing to http://bzr.example.com/api/review-requests/28/diffs/: 
{'basedir': '/'}
>>> Got API Error 219 (HTTP code 400): The specified diff file is empty
>>> Error data: {u'stat': u'fail', u'err': {u'msg': u'The specified diff 
file is empty', u'code': 219}}

Error uploading diff

Your review request still exists, but the diff is not attached.

On Thursday, February 28, 2013 11:02:33 AM UTC-8, WW Li wrote:
> I figured it out by passing --server=<my reviewboard url>
> I ran "post-review --server=<my reviewboard url> --repository-url=<my 
> repository url>"  but I got this error
> Error uploading diff
> Your review request still exists, but the diff is not attached.
> On Thursday, February 28, 2013 10:09:29 AM UTC-8, WW Li wrote:
>> Hi All,
>> I am trying to setting up post-review tool bazaar. I looked into this 
>> page http://www.reviewboard.org/docs/manual/1.7/users/tools/post-review/. It 
>> seems missing configuration docs for bazaar.
>> When I ran post-review in my bazaar repository I saw this error
>> "Unable to find a Review Board server for this source code tree."
>> Thanks.

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to