Hi Steve,

I'm not aware off-hand of any changes that would have broken whitespace changes 
within a line. Definitely something that we need to fix if this is reproducible.

Do you see anything in the browser's console log when you click the Show 
Whitespace Changes?

What version of 1.6 are you testing in the sandbox?

Christian


On Apr 26, 2013, at 8:29, Steve <seide.al...@gmail.com> wrote:

> We have 1.7.6 in production on a linux server. I posted a review of a php 
> file with whitespace-only diffs on one line. When I view it on reviewboard it 
> won't show me the diff.  With these settings:
> 
> + Expand Changes    + Show Whitespace changes
> 
> I see the message:
> 
> "This file contains only whitespace changes."
> 
> That makes sense.  When I click on the 'Show Whitespace changes' box, I still 
> don't see any diff.
> 
> 
> I posted the same exact review to my 1.6 sandbox, and there it behaves the 
> way I would expect, namely when I click on the "Show Whitespace changes", I 
> see my 1 line diff.
> 
> This is a serious problem because those whitespace differences are not 
> leading/trailing spaces and they're significant to the change under review.
> 
> I compared my site settings for the diff viewer, I don't see anything that 
> jumps out at me. Maybe something will jump out at you:
> 
> # 1.6 server that behaves the way I want
>  u'diffviewer_context_num_lines': 5,
>  u'diffviewer_include_space_patterns': [u''],
>  u'diffviewer_max_diff_size': 0,
>  u'diffviewer_paginate_by': 20,
>  u'diffviewer_paginate_orphans': 10,
>  u'diffviewer_show_trailing_whitespace': False,
>  u'diffviewer_syntax_highlighting': True,
>  u'diffviewer_syntax_highlighting_threshold': 0,
> 
> # 1.7.6 server that does not behave the way I want
>  u'diffviewer_context_num_lines': 7,
>  u'diffviewer_include_space_patterns': [u''],
>  u'diffviewer_max_diff_size': 0,
>  u'diffviewer_paginate_by': 10,
>  u'diffviewer_paginate_orphans': 3,
>  u'diffviewer_show_trailing_whitespace': False,
>  u'diffviewer_syntax_highlighting': True,
>  u'diffviewer_syntax_highlighting_threshold': None,
> 
> 
> I don't know why the last setting is 0 for 1.6 and None for 1.7. They seem 
> logically the same and not related to whitespace, but I obviously don't know 
> that for sure. The 1.7.6 database was migrated from a 1.5 server so maybe 
> that's why.  The 1.6 sandbox was created from scratch.
> 
> Is this a bug, or do I have something misconfigured?
> 
> 
> --Steve
> 
> -- 
> Want to help the Review Board project? Donate today at 
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to 
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at 
> http://groups.google.com/group/reviewboard?hl=en
> --- 
> You received this message because you are subscribed to the Google Groups 
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>  
>  

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to