HI,

Ours is base clearcase Enviroment .Our Reviewboard  server is LINUX rhel 
machine with RB version 1.6.3 .i am running post-review from Linux hosts 
having rb tools 0.4.1  

I am facing same  issue while uploading existing diff file using "*post-review 
--diff-filename"* from linux host ..The review is getting created but the 
diff file is not getting uploaded from command line post-review  .I can 
upload the diff file from GUI to the appropriate review ID but failing 
 from commandline "*post-review --diff-filename"*

Let me know if any specfic Server side configuration missing  ?  Please 
help .

Error:

14 % *post-review --diff-filename=d1.diff --server="https://MyRbServer";  -d*
>>> RBTools 0.4.1
>>> Home = /emc/ppreleng
>>> HTTP GETting api/
>>> HTTP GETting https://MyRbServer/api/info/
>>> Using the new web API
>>> HTTP GETting https://MyRbServer/api/repositories/
>>> HTTP GETting https://MyRbServer/api/repositories/1/
>>> HTTP GETting https://MyRbServer/api/repositories/1/info/
>>> HTTP GETting https://MyRbServer/api/repositories/2/
>>> HTTP GETting https://MyRbServer/api/repositories/2/info/
>>> HTTP GETting https://MyRbServer/api/repositories/3/
>>> HTTP GETting https://MyRbServer/api/repositories/3/info/
>>> Attempting to create review request on 
/view/ppreleng_reviewboardAdmin/vobs/ms-test for None
>>> HTTP POSTing to https://MyRbServer/api/review-requests/: {'repository': 
u'/view/ppreleng_reviewboardAdmin/vobs/ms-test'}
>>> Review request created
>>> Uploading diff, size: 27
>>> HTTP POSTing to https://MyRbServer/api/review-requests/370/diffs/: 
{'basedir': u'/view/ppreleng_reviewboardAdmin/vobs/ms-test'}
*>>> Got API Error 105 (HTTP code 400): One or more fields had errors*
*>>> Error data: {u'fields': {u'path': [u'The diff file is empty']}, 
u'stat': u'fail', u'err': {u'msg': u'One or more fields had errors', 
u'code': 105}}*

Error uploading diff

The generated diff file was empty. This usually means no files were
modified in this change.

Try running with --output-diff and --debug for more information.

Your review request still exists, but the diff is not attached.

On Tuesday, October 30, 2012 2:14:29 PM UTC+5:30, Alvin NG wrote:
>
> Hi, 
>
> I could not attach the difference between revisions to my review. 
> It gives me the error "Got API Error 105 (HTTP code 400): One or more 
> fields had errors". 
> I have also tried to output the difference by using svn diff and 
> attach the file to my review, but it still gives me the same error. 
>
> My command: post-review --server=http://localhost/reviewboard --debug 
> --disable-proxy --target-group=proj_test -- revision=0:11 --diff- 
> filename=diff.txt 
>
> (I'm not sure if this would also help) The repository server of my 
> Reviewboard is like this svn://localhost/test_proj but not the local 
> path to the reviewboard server 
>
> Many thanks, 
> Alvin 
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to