Hello!

I just tried to upgrade current RB 1.7.7.1 to 1.7.16 version as described 
in RB upgrade procedure. I should mention that my PC is using proxy, so 
before that I exported http_proxy and https_proxy.

sudo easy_install -U ReviewBoard


Output:

> Searching for ReviewBoard

Reading http://pypi.python.org/simple/ReviewBoard/

Download error: [Errno 110] Connection timed out -- Some packages may not 
> be found!

Couldn't retrieve index page for 'ReviewBoard'

Scanning index of all packages (this may take a while)

Reading http://pypi.python.org/simple/

Download error: [Errno 110] Connection timed out -- Some packages may not 
> be found!

Best match: ReviewBoard 1.7.16

Processing ReviewBoard-1.7.16-py2.7.egg

ReviewBoard 1.7.16 is already the active version in easy-install.pth

Installing rb-site script to /usr/local/bin

Installing rbssh script to /usr/local/bin


> Using /usr/local/lib/python2.7/dist-packages/ReviewBoard-1.7.16-py2.7.egg

Reading http://downloads.reviewboard.org/mirror/

Download error: [Errno 110] Connection timed out -- Some packages may not 
> be found!

Reading http://downloads.reviewboard.org/releases/ReviewBoard/1.7/

Download error: [Errno 110] Connection timed out -- Some packages may not 
> be found!

Processing dependencies for ReviewBoard

Finished processing dependencies for ReviewBoard 


Upgrade installed site; restart apache and memcached.

After refreshing webpage i got message:
"
Review Board is taking a nap
There are several possible reasons:
   
   - We're updating it.
   - You're trying to look at a really huge diff without collapsing, and it 
   timed out (try viewing another diff and going back to collapsed changes; 
   we're working on fixing this).
   - Our lazy good-for-nothing oompa-loompas stopped pedalling.

It'll be back soon."

And I found this in apache error.log:

[Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1] mod_wsgi (pid=13908): 
>> Exception occurred processing WSGI script 
>> '/var/www/reviewboard177/htdocs/reviewboard.wsgi'., referer: 
>> http://localhost/reviewboard177/r/
>
> [Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1] Traceback (most 
>> recent call last):, referer: http://localhost/reviewboard177/r/
>
> [Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1]   File 
>> "/usr/local/lib/python2.7/dist-packages/Django-1.4.8-py2.7.egg/django/core/handlers/wsgi.py",
>>  
>> line 219, in __call__, referer: http://localhost/reviewboard177/r/
>
> [Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1]     
>> self.load_middleware(), referer: http://localhost/reviewboard177/r/
>
> [Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1]   File 
>> "/usr/local/lib/python2.7/dist-packages/Django-1.4.8-py2.7.egg/django/core/handlers/base.py",
>>  
>> line 51, in load_middleware, referer: http://localhost/reviewboard177/r/
>
> [Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1]     raise 
>> exceptions.ImproperlyConfigured('Middleware module "%s" does not define a 
>> "%s" class' % (mw_module, mw_classname)), referer: 
>> http://localhost/reviewboard177/r/
>
> [Tue Oct 22 12:07:47 2013] [error] [client 127.0.0.1] 
>> ImproperlyConfigured: Middleware module "djblets.extensions.middleware" 
>> does not define a "ExtensionsMiddlewareRunner" class, referer: 
>> http://localhost/reviewboard177/r/
>
> [Tue Oct 22 14:07:47 2013] [error] [client 127.0.0.1] File does not exist: 
>> /var/www/reviewboard177/htdocs/favicon.ico
>
>
 Any suggestions?

Thank You!

Robcikss

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to