Hi Roberto,

The "No address associated with hostname" looks at first to be the real
problem. I would expect that error to appear earlier than it did in the
process, though.

As a sanity check, try verifying that if you SSH into the Review Board
server, you're able to resolve the hostname you used. I expect it will
work, but just to check.

Also, from the command line, try SSHing into your Git server (assuming it
allows remote access) using rbssh. If that fails, try with:

    DEBUG_RBSSH=1 rbssh <parameters>

There should then be a log file in the current directory with more details
of the attempt.

So, regardless of this error, you cannot use Review Board with a remote Git
repository without a raw file URL mask field filled in. Git has no ability
to fetch individual files from a repository without a full clone, and this
is a problem for Review Board. So, you will need something like cgit or
gitweb sitting on top of your Git repository, and the fields properly
filled in. We have some examples in our docs at
http://www.reviewboard.org/docs/manual/1.7/admin/configuration/repositories/#git

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com


On Sun, Oct 27, 2013 at 5:00 AM, Roberto Druetto
<roberto.drue...@gmail.com>wrote:

> Hi guys,
>
> I am trying to install reviewboard but I have a problem when I try to add
> a new git repository.
>
> This is what I have in my conf:
>
> Repository type: git
> Path: ssh://USERNAME@HOSTNAME:2022/PATH_OF_MY_GIT_REPO.git
>
> Nothing else in the other properties.
>
> When I press the Add Repository button I get:
>
>    - [Errno -5] No address associated with hostname
>
> And when I check the logs I see this:
>
> 2013-10-27 11:49:25,453 - DEBUG -  - GitTool: Attempting ssh connection
> with host: stash.ops.aol.com:2022, username: USERNAME
> 2013-10-27 11:49:25,567 - DEBUG -  - starting thread (client mode):
> 0x64090c50L
> 2013-10-27 11:49:25,678 - INFO -  - Connected (version 2.0, client
> SSHD-CORE-0.7.0-ATLASSIAN-M3)
> 2013-10-27 11:49:25,678 - DEBUG -  - kex
> algos:['diffie-hellman-group14-sha1', 'diffie-hellman-group1-sha1'] server
> key:['ssh-rsa'] client encrypt:['aes128-cbc', '3des-cbc', 'blowfish-cbc']
> server encrypt:['aes128-cbc', '3des-cbc', 'blowfish-cbc'] client
> mac:['hmac-md5', 'hmac-sha1', 'hmac-md5-96', 'hmac-sha1-96'] server
> mac:['hmac-md5', 'hmac-sha1', 'hmac-md5-96', 'hmac-sha1-96'] client
> compress:['none'] server compress:['none'] client lang:[''] server
> lang:[''] kex follows?False
> 2013-10-27 11:49:25,679 - DEBUG -  - Ciphers agreed: local=aes128-cbc,
> remote=aes128-cbc
> 2013-10-27 11:49:25,679 - DEBUG -  - using kex diffie-hellman-group1-sha1;
> server key type ssh-rsa; cipher: local aes128-cbc, remote aes128-cbc; mac:
> local hmac-sha1, remote hmac-sha1; compression: local none, remote none
> 2013-10-27 11:49:25,931 - DEBUG -  - Switch to new keys ...
> 2013-10-27 11:49:26,232 - DEBUG -  - EOF in transport thread
>
> To me it looks like reviewboard is not using the right ssh keys to connect
> to my repo. I have obviously added on my git repo the keys for: reviewboard
> (generate through the tool), www-data gneerated in my linux box where I
> store reviewboard and my user (which has the same name as the git repo).
> Nothing changes.
>
> If I try to manually clone the repository it works perfectly, even by
> using the www-data user.
>
> Any idea on what I am doing wrong? My reviewboard version is 1.7.16
>
> Thanks!
>
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to