Hi Thomas,

I'm not at the computer right now so I can't verify, but I believe you just
need to specify that username/password in the Username/Password fields in
the repo config and it should use them during authentication.

Christian


On Monday, December 16, 2013, Thomas Dahlin wrote:

> Nobody else had/having this problem?
>
> On Tuesday, December 10, 2013 6:08:32 PM UTC+1, Thomas Dahlin wrote:
>
> I am currently trying to setup RB version 1.7.19 on a Ubuntu machine to
> evaluate the tool in our organisation.
>
> I am currently stuck at getting the git integration properly configured.
>
> This is my what I have entered (fake values marked with yellow)
>
> *Hosting service*: (None - Custom Repository)
> *Repository type*: Git
> *Path*: g...@git.example.com:projectname.git
> *Raw file URL mask*: https://servername/?p=projectname.git;a=blob;f=<
> filename>;h=<revision>
>
> ------------------------
>
> Executing this on the local win machine:
>
> $ rbt post -d --tracking-branch=topics/branch/name
> DEBUG:root:Checking for a Subversion repository...
> DEBUG:root:Checking for a Git repository...
> DEBUG:root:Running: git rev-parse --git-dir
> DEBUG:root:Running: git config core.bare
> DEBUG:root:Running: git rev-parse --show-toplevel
> DEBUG:root:Running: git symbolic-ref -q HEAD
> DEBUG:root:Running: git config --get git-p4.port
> DEBUG:root:Command exited with rc 1: ['git', 'config', '--get',
> 'git-p4.port']
> ---
> DEBUG:root:Running: git config --get branch.topics/branch/name.merge
> DEBUG:root:Running: git config --get branch.topics/branch/name.remote
> DEBUG:root:Running: git config --get remote.origin.url
> DEBUG:root:repository info: Path: g...@git.example.com:projectname.git,
> Base path: , Supports changesets: False
> DEBUG:root:Making HTTP GET request to http://<RB server>/api/
> DEBUG:root:Making HTTP GET request to http://<RB server>/api/info/
> DEBUG:root:Running: git merge-base origin/topics/branch/name refs/heads/
> topics/branch/name
> DEBUG:root:Running: git diff --no-color --full-index --no-ext-diff
> --ignore-submodules --no-renames <revision>..refs/heads/topics/branch/name
>  -M
> DEBUG:root:Making HTTP GET request to http://<RB server>
> /api/review-requests/
> DEBUG:root:Making HTTP POST request to http://<RB server>
> /api/review-requests/
>
> DEBUG:root:Making HTTP GET request to http://<RB server>
> /api/review-requests/1/diffs/
> DEBUG:root:Making HTTP POST request to http://<RB server>
> /api/review-requests/1/diffs/
> DEBUG:root:Got API Error 207 (HTTP code 400): The file was not found in
> the repository
> DEBUG:root:Error data: {u'stat': u'fail', u'file': u'
>
>  --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com <javascript:_e({},
> 'cvml', 'reviewboard%2bunsubscr...@googlegroups.com');>.
> For more options, visit https://groups.google.com/groups/opt_out.
>


-- 
-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to