If you could spin one up with the latest 1.7.x, that'd help a lot with
testing. Much has changed since 1.7.9.

I'm finishing up some other work, but I'll send some patches in a bit.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com


On Thu, Dec 19, 2013 at 1:55 PM, Javins, Walt <walt.jav...@isilon.com>wrote:

>  I’m fine applying patches or using easy_install.  I’m running python
> 2.6.6 on centos 6.2.  I could easily spin up a new sandbox if you need me
> to test with  a more current X.
>
>
>
> Walt
>
>
>
> *From:* reviewboard@googlegroups.com [mailto:reviewboard@googlegroups.com]
> *On Behalf Of *Christian Hammond
> *Sent:* Thursday, December 19, 2013 12:38 PM
>
> *To:* reviewboard@googlegroups.com
> *Subject:* Re: git config issues
>
>
>
> Can you let me know what version of Python you're using? Also, would you
> be okay with a patch file, or would you prefer I send you a new egg?
>
>
>
> Christian
>
>
>   --
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
>
> Beanbag, Inc. - http://www.beanbaginc.com
>
>
>
> On Thu, Dec 19, 2013 at 12:36 PM, Javins, Walt <walt.jav...@isilon.com>
> wrote:
>
> If Thomas is otherwise busy, I can also contribute some time for sandbox
> testing and debugging of this issue.
>
>
>
> Walt
>
>
>
> *From:* reviewboard@googlegroups.com [mailto:reviewboard@googlegroups.com]
> *On Behalf Of *Christian Hammond
> *Sent:* Thursday, December 19, 2013 12:30 PM
>
>
> *To:* reviewboard@googlegroups.com
> *Subject:* Re: git config issues
>
>
>
> Hi Thomas,
>
>
>
> Hmm, I've spent some time looking through the code and it looks like it
> *should* be working.
>
>
>
> Would you be willing to continue working on this if I send you some builds
> with enhanced logging and possible fixes?
>
>
>
> Christian
>
>
>   --
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
>
> Beanbag, Inc. - http://www.beanbaginc.com
>
>
>
> On Thu, Dec 19, 2013 at 8:08 AM, Thomas Dahlin <thomas.g.dah...@gmail.com>
> wrote:
>
> Hi Christian,
>
>
>
> Nah, I can't get it to work. I tried entering the credentials in the
> Username and Password fields. I also had to add hb=HEAD to the raw file URL
> mask to be able to use a browser to get the info. I have now:
>
>
>
> *Hosting service*: (None - Custom Repository)
>
> *Repository type*: Git
>
> *Path*: g...@git.example.com:projectname.git
>
> *Raw file URL mask*: https://servername/?p=projectname.git;a=blob;f=
> <filename>;h=<revision>;hb=HEAD
>
> *Username*: <username>
>
> *Password*: <password>
>
>
>
>
>
> Still getting "HTTP Error 401: Authorization Required" in the RB server
> logs
>
>
>
> It doesn't feel like RB is providing the entered username/password
> information...
>
>
>
> Giving up. I didn't think I was going to spend THIS much time just
> configuring this (what appears to be a) great tool! If any of you guys have
> any good ideas I'm more than willing to try them out. I'm all out of ideas.
>
>
>
>
>
> Thanks in advance!
>
>
>
> /Thomas
>
>
>
>
>
> On Tuesday, December 10, 2013 6:08:32 PM UTC+1, Thomas Dahlin wrote:
>
>  I am currently trying to setup RB version 1.7.19 on a Ubuntu machine to
> evaluate the tool in our organisation.
>
>
>
> I am currently stuck at getting the git integration properly configured.
>
>
>
> This is my what I have entered (fake values marked with yellow)
>
>
>
> *Hosting service*: (None - Custom Repository)
>
> *Repository type*: Git
>
> *Path*: g...@git.example.com:projectname.git
>
> *Raw file URL mask*: https://servername/?p=projectname.git;a=blob;f=
> <filename>;h=<revision>
>
>
>
> ------------------------
>
>
>
> Executing this on the local win machine:
>
>
>
> $ rbt post -d --tracking-branch=topics/branch/name
>
> DEBUG:root:Checking for a Subversion repository...
>
> DEBUG:root:Checking for a Git repository...
>
> DEBUG:root:Running: git rev-parse --git-dir
>
> DEBUG:root:Running: git config core.bare
>
> DEBUG:root:Running: git rev-parse --show-toplevel
>
> DEBUG:root:Running: git symbolic-ref -q HEAD
>
> DEBUG:root:Running: git config --get git-p4.port
>
> DEBUG:root:Command exited with rc 1: ['git', 'config', '--get',
> 'git-p4.port']
>
> ---
>
> DEBUG:root:Running: git config --get branch.topics/branch/name.merge
>
> DEBUG:root:Running: git config --get branch.topics/branch/name.remote
>
> DEBUG:root:Running: git config --get remote.origin.url
>
> DEBUG:root:repository info: Path: g...@git.example.com:projectname.git,
> Base path: , Supports changesets: False
>
> DEBUG:root:Making HTTP GET request to http://<RB server>/api/
>
> DEBUG:root:Making HTTP GET request to http://<RB server>/api/info/
>
> DEBUG:root:Running: git merge-base origin/topics/branch/name refs/heads/
> topics/branch/name
>
> DEBUG:root:Running: git diff --no-color --full-index --no-ext-diff
> --ignore-submodules --no-renames <revision>..refs/heads/topics/branch/name
>  -M
>
> DEBUG:root:Making HTTP GET request to http://<RB server>
> /api/review-requests/
>
> DEBUG:root:Making HTTP POST request to http://<RB server>
> /api/review-requests/
>
>
>
> DEBUG:root:Making HTTP GET request to http://<RB server>
> /api/review-requests/1/diffs/
>
> DEBUG:root:Making HTTP POST request to http://<RB server>
> /api/review-requests/1/diffs/
>
> DEBUG:root:Got API Error 207 (HTTP code 400): The file was not found in
> the repository
>
> DEBUG:root:Error data: {u'stat': u'fail', u'file': u'<filename>', u'err':
> {u'msg': u'The file was not found in the repository', u'code': 207},
> u'revision': u'<revision>'}
>
> Traceback (most recent call last):
>
>   File "c:\Python27\Scripts\rbt-script.py", line 9, in <module>
>
>     load_entry_point('RBTools==0.5.2', 'console_scripts', 'rbt')()
>
>   File
> "C:\Python27\lib\site-packages\rbtools-0.5.2-py2.7.egg\rbtools\commands\main.py",
> line 106, in main
>
>   File
> "C:\Python27\lib\site-packages\rbtools-0.5.2-py2.7.egg\rbtools\commands\__init__.py",
> line 157, in run_from_argv
>
>   File
> "C:\Python27\lib\site-packages\rbtools-0.5.2-py2.7.egg\rbtools\commands\post.py",
> line 511, in main
>
>   File
> "C:\Python27\lib\site-packages\rbtools-0.5.2-py2.7.egg\rbtools\commands\post.py",
> line 390, in post_request
>
> rbtools.commands.CommandError: Error uploading diff
>
>
>
>
>
> The file was not found in the repository (HTTP 400, API Error 207)
>
>
>
> Your review request still exists, but the diff is not attached.
>
>
>
> ------------------
>
>
>
> RB logs:
>
>
>
> DEBUG - - userauth is OK
> DEBUG - - Debug msg: Forced command: gitosis-serve xxxxxxxx
> DEBUG - - Debug msg: Port forwarding disabled.
> DEBUG - - Debug msg: X11 forwarding disabled.
> DEBUG - - Debug msg: Agent forwarding disabled.
> DEBUG - - Debug msg: Pty allocation disabled.
> INFO - - Authentication (publickey) successful!
> DEBUG - - EOF in transport thread
> INFO - - Fetching file from
> https://servername/?p=projectname.git;a=blob;f=<filename>;hb=<revision>
> ERROR - - HTTP error code 401 when fetching file from
> https://servername/?p=projectname.git;a=blob;f=<filename>;h=<revision>:
> HTTP Error 401: Authorization Required
>
> -------------------
>
>
>
> I found someone reported a similar issue:
> https://code.google.com/p/reviewboard/issues/detail?id=3058
>
>
>
> If I try setting the *Raw file URL mask* as suggested in #9 ("*You can
> encode these in the URL as https://username:password@myServerAddress/*";), I
> get the following error (on the RB server):
>
>
>
> ERROR -  - Unexpected error fetching file from https://username
> :password@servername/?p=projectname.git;a=blob;f=<filename>;h=<revision>:
> nonnumeric port: 'password@servername'
>
>
>
>
>
> Thanks in advance! I really want to get this up and running!
>
>
>
>     --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
>
>
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to