I am using ReviewBoard 1.7.20 , I installed using following command on
ubuntu 12.04

easy_install reviewboard.

Thanks.

--Kapil


On Wed, Jan 8, 2014 at 3:35 PM, Christian Hammond <chip...@chipx86.com>wrote:

> Can you tell me what version of Review Board you're using? We made some
> fixes to BitBucket support a couple releases ago.
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> Beanbag, Inc. - http://www.beanbaginc.com
>
>
> On Wed, Jan 8, 2014 at 8:03 AM, Kapil Anand <kapilana...@gmail.com> wrote:
>
>> Hi,
>>
>> I am also facing the same issue while linking my private bitbuket repo to
>> Review Board. Is there a workaround to this issue?
>>
>> Thanks
>>
>> --Kapil
>>
>>
>> On Thursday, August 29, 2013 1:44:34 PM UTC-4, Benn Bollay wrote:
>>
>>> Hello folks -
>>>
>>> First, vital stats:
>>> RB 1.7.13
>>> SSH OpenSSH_5_9.p1
>>> Ubuntu 12.04
>>> Private repository hosted on bitbucket with both ssh keys added for the
>>> user, and a custom user created for reviewboard.
>>>
>>> I try to go to add the repository:
>>> I set the hosting service to bitbucket, and set the "Repository name" to
>>> 'repo'
>>>
>>> This generates an error at the top with "Please correct the error
>>> below", and then an empty <li></li> below it where error text should be.
>>> Nothing shows up in the logs.
>>>
>>> If I try 'https://u...@bitbucket.org/team/repo' or 'ssh://
>>> h...@bitbucket.org/team/repo', the same thing occurs.  No output in the
>>> logfile (it's set to debug), and no errors listed.
>>>
>>> If I set it to 'Custom repostitory' and put the 'ssh' line in as the
>>> location, I get this output in the debug log:
>>>
>>> 2013-08-29 17:42:12,311 - DEBUG -  - HgTool: Attempting ssh connection
>>>> with host: bitbucket.org, username: hg
>>>> 2013-08-29 17:42:12,311 - DEBUG -  - HgTool: Attempting ssh connection
>>>> with host: bitbucket.org, username: hg
>>>> 2013-08-29 17:42:12,409 - DEBUG -  - starting thread (client mode):
>>>> 0x9c4db050L
>>>> 2013-08-29 17:42:12,409 - DEBUG -  - starting thread (client mode):
>>>> 0x9c4db050L
>>>> 2013-08-29 17:42:12,498 - INFO -  - Connected (version 2.0, client
>>>> OpenSSH_5.3)
>>>> 2013-08-29 17:42:12,498 - INFO -  - Connected (version 2.0, client
>>>> OpenSSH_5.3)
>>>> 2013-08-29 17:42:12,502 - DEBUG -  - kex 
>>>> algos:['diffie-hellman-group-exchange-sha256',
>>>> 'diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1',
>>>> 'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client
>>>> encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256',
>>>> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc',
>>>> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijnda...@lysator.liu.se']
>>>> server encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256',
>>>> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc',
>>>> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijnda...@lysator.liu.se']
>>>> client mac:['hmac-md5', 'hmac-sha1', 'uma...@openssh.com',
>>>> 'hmac-ripemd160', 'hmac-ri...@openssh.com', 'hmac-sha1-96',
>>>> 'hmac-md5-96'] server mac:['hmac-md5', 'hmac-sha1', 'uma...@openssh.com',
>>>> 'hmac-ripemd160', 'hmac-ri...@openssh.com', 'hmac-sha1-96',
>>>> 'hmac-md5-96'] client compress:['none', 'zl...@openssh.com'] server
>>>> compress:['none', 'zl...@openssh.com'] client lang:[''] server
>>>> lang:[''] kex follows?False
>>>> 2013-08-29 17:42:12,502 - DEBUG -  - kex 
>>>> algos:['diffie-hellman-group-exchange-sha256',
>>>> 'diffie-hellman-group-exchange-sha1', 'diffie-hellman-group14-sha1',
>>>> 'diffie-hellman-group1-sha1'] server key:['ssh-rsa', 'ssh-dss'] client
>>>> encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256',
>>>> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc',
>>>> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijnda...@lysator.liu.se']
>>>> server encrypt:['aes128-ctr', 'aes192-ctr', 'aes256-ctr', 'arcfour256',
>>>> 'arcfour128', 'aes128-cbc', '3des-cbc', 'blowfish-cbc', 'cast128-cbc',
>>>> 'aes192-cbc', 'aes256-cbc', 'arcfour', 'rijnda...@lysator.liu.se']
>>>> client mac:['hmac-md5', 'hmac-sha1', 'uma...@openssh.com',
>>>> 'hmac-ripemd160', 'hmac-ri...@openssh.com', 'hmac-sha1-96',
>>>> 'hmac-md5-96'] server mac:['hmac-md5', 'hmac-sha1', 'uma...@openssh.com',
>>>> 'hmac-ripemd160', 'hmac-ri...@openssh.com', 'hmac-sha1-96',
>>>> 'hmac-md5-96'] client compress:['none', 'zl...@openssh.com'] server
>>>> compress:['none', 'zl...@openssh.com'] client lang:[''] server
>>>> lang:[''] kex follows?False
>>>>
>>>> 2013-08-29 17:42:12,502 - DEBUG -  - Ciphers agreed: local=aes128-ctr,
>>>> remote=aes128-ctr
>>>> 2013-08-29 17:42:12,502 - DEBUG -  - Ciphers agreed: local=aes128-ctr,
>>>> remote=aes128-ctr
>>>> 2013-08-29 17:42:12,503 - DEBUG -  - using kex
>>>> diffie-hellman-group1-sha1; server key type ssh-rsa; cipher: local
>>>> aes128-ctr, remote aes128-ctr; mac: local hmac-sha1, remote hmac-sha1;
>>>> compression: local none, remote none
>>>> 2013-08-29 17:42:12,503 - DEBUG -  - using kex
>>>> diffie-hellman-group1-sha1; server key type ssh-rsa; cipher: local
>>>> aes128-ctr, remote aes128-ctr; mac: local hmac-sha1, remote hmac-sha1;
>>>> compression: local none, remote none
>>>> 2013-08-29 17:42:12,744 - DEBUG -  - Switch to new keys ...
>>>> 2013-08-29 17:42:12,744 - DEBUG -  - Switch to new keys ...
>>>> 2013-08-29 17:42:12,747 - DEBUG -  - Trying SSH key <...>
>>>> 2013-08-29 17:42:12,747 - DEBUG -  - Trying SSH key <...>
>>>> 2013-08-29 17:42:12,945 - DEBUG -  - userauth is OK
>>>> 2013-08-29 17:42:12,945 - DEBUG -  - userauth is OK
>>>> 2013-08-29 17:42:13,124 - DEBUG -  - Debug msg: Forced command: conq
>>>> username:user
>>>> 2013-08-29 17:42:13,124 - DEBUG -  - Debug msg: Forced command: conq
>>>> username:user
>>>> 2013-08-29 17:42:13,125 - DEBUG -  - Debug msg: Port forwarding
>>>> disabled.
>>>> 2013-08-29 17:42:13,125 - DEBUG -  - Debug msg: Port forwarding
>>>> disabled.
>>>> 2013-08-29 17:42:13,126 - DEBUG -  - Debug msg: X11 forwarding disabled.
>>>> 2013-08-29 17:42:13,126 - DEBUG -  - Debug msg: X11 forwarding disabled.
>>>> 2013-08-29 17:42:13,127 - DEBUG -  - Debug msg: Agent forwarding
>>>> disabled.
>>>> 2013-08-29 17:42:13,127 - DEBUG -  - Debug msg: Agent forwarding
>>>> disabled.
>>>> 2013-08-29 17:42:13,128 - DEBUG -  - Debug msg: Pty allocation disabled.
>>>> 2013-08-29 17:42:13,128 - DEBUG -  - Debug msg: Pty allocation disabled.
>>>> 2013-08-29 17:42:13,130 - INFO -  - Authentication (publickey)
>>>> successful!
>>>> 2013-08-29 17:42:13,130 - INFO -  - Authentication (publickey)
>>>> successful!
>>>> 2013-08-29 17:42:13,231 - DEBUG -  - EOF in transport thread
>>>> 2013-08-29 17:42:13,231 - DEBUG -  - EOF in transport thread
>>>> 2013-08-29 17:42:13,246 - DEBUG -  - Using rbssh for mercurial
>>>> 2013-08-29 17:42:13,246 - DEBUG -  - Using rbssh for mercurial
>>>> 2013-08-29 17:42:13,262 - ERROR -  - Error connecting to Mercurial
>>>> repository ssh://h...@bitbucket.org/team/repo: no suitable response from
>>>> remote hg
>>>> 2013-08-29 17:42:13,262 - ERROR -  - Error connecting to Mercurial
>>>> repository ssh://h...@bitbucket.org/team/repo: no suitable response from
>>>> remote hg
>>>>
>>>
>>> Any ideas, suggestions, thoughts?
>>>
>>> Cheers,
>>> --B
>>>
>>  --
>> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
>> ---
>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>> ---
>>
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> ---
>> You received this message because you are subscribed to the Google Groups
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to reviewboard+unsubscr...@googlegroups.com.
>>
>> For more options, visit https://groups.google.com/groups/opt_out.
>>
>
>  --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to a topic in the
> Google Groups "reviewboard" group.
> To unsubscribe from this topic, visit
> https://groups.google.com/d/topic/reviewboard/NAr7CIwMaSw/unsubscribe.
> To unsubscribe from this group and all its topics, send an email to
> reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to