Hi Tim,

That's concerning. This should only be able to happen if accessing the site
configuration data throws an exception, which shouldn't happen.

What was the repro case? Just going to a URL?

Try this and see what happens:

    $ rb-site manage /path/to/site shell
    >>> from djblets.siteconfig.models import SiteConfiguration
    >>> SiteConfiguration.objects.get_current()

See if that raises an exception.

If not,
edit 
/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0beta3-py2.7.egg/reviewboard/admin/siteconfig.py
and find this code:

    try:
        siteconfig = SiteConfiguration.objects.get_current()
    except SiteConfiguration.DoesNotExist:
        raise ImproperlyConfigured(
            "The site configuration entry does not exist in the database. "
            "Re-run `./manage.py` syncdb to fix this.")
    except:
        # We got something else. Likely, this doesn't exist yet and we're
        # doing a syncdb or something, so silently ignore.
        return

Change that last 'return' to 'raise', reload Apache, and repro again. See
what error comes up.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com


On Tue, Feb 25, 2014 at 9:09 AM, timc <timcuss...@gmail.com> wrote:

> Hi all,
>
> I've just upgraded a Debian Wheezy VM to the latest beta and I'm hitting
> an issue straight off the bat:
>
> http://dpaste.com/1658355/
>
> Context:
>
> - We're using beta2 on another VM, mysql backend. Running fine.
> - I cloned the VM and upgraded the new VM's Review Board using recommended
> method.
> - I created a new site using rb-site, no hassles, sqlite3 backend.
>
> If anyone's got a clue on this one, it'd be much appreciated.
> Alternatively, let me know what other information will be useful!
>
> Cheers,
> Tim
>
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to