stuck on ldap :(, any idea how to get this going?

On Wednesday, December 18, 2013 11:41:08 PM UTC-8, Mayur T wrote:
>
> I guess after this thread, no more suggestions provided.
> I am exactly struck at the same place. If I do ldapsearch from command, I 
> am able to get the search success. But if I give exactly same as mentioned 
> with Anaonymous user and password, I get bind error still.
> Please review board help.
>
> On Wednesday, October 5, 2011 5:57:58 PM UTC+8, jack jack wrote:
>>
>> Thats fine !! why the field is empty its should be marked as  ***** 
>> atleast
>>
>> On Wed, Oct 5, 2011 at 3:21 PM, Christian Hammond <chi...@chipx86.com>wrote:
>>
>>> Django purposefully doesn't fill in the password, as a security measure.
>>>
>>>
>>> Christian
>>>
>>> -- 
>>> Christian Hammond - chi...@chipx86.com
>>> Review Board - http://www.reviewboard.org
>>> VMware, Inc. - http://www.vmware.com
>>>
>>>
>>> On Wed, Oct 5, 2011 at 1:56 AM, jack jack <jai...@gmail.com> wrote:
>>>
>>>> Dear All,
>>>>
>>>> Could you please help me with your input.
>>>>
>>>> After adding entry ( Anonymous User Password:) in the LDAP 
>>>> configuration and save the configuration, but when i open the page again 
>>>> the password field got empty.
>>>>
>>>> If this is the bug then what should be the workaround for this....I got 
>>>> stuck now.
>>>>
>>>> Please extend your expert comments and help me with the solution... 
>>>>
>>>> Regards,
>>>> Jack
>>>>
>>>>
>>>> On Mon, Oct 3, 2011 at 11:51 PM, jack jack <jai...@gmail.com> wrote:
>>>>
>>>>> Hello Stephen,Chris,
>>>>>
>>>>> Here is my old custom method of authenticating through LDAP, I have 
>>>>> taken these snippet from httpd.conf Please help me with these entries to 
>>>>> configure LDAP in RB
>>>>>
>>>>> AuthType Basic
>>>>> AuthBasicProvider ldap
>>>>> AuthName "Enter your Windows login (without domain qualifier)"
>>>>> AuthzLDAPAuthoritative  off
>>>>> AuthzLDAPAuthoritative  on
>>>>> AuthLDAPBindDN "CN=ldapquery,OU=Service Accounts,OU=Exception 
>>>>> Accounts,DC=na,DC=xxxxxxware,DC=com"
>>>>> AuthLDAPBindPassword "$$$$$$$$$"
>>>>> AuthLDAPURL "ldap://
>>>>> nascmdc01.na.xxxxxxware.com:3268/dc=xxxxxxware,dc=com?sAMAccountName?sub?(memberOf=CN=pdpm,OU=Security<http://nascmdc01.na.xxxxxxware.com:3268/dc=xxxxxxware,dc=com?sAMAccountName?sub?%28memberOf=CN=pdpm,OU=Security>Groups,OU=Group
>>>>>  Accounts,DC=na,DC=xxxxxxware,DC=com)
>>>>> Require valid-user
>>>>>
>>>>> Appreciate your help.
>>>>>
>>>>>
>>>>> On Mon, Oct 3, 2011 at 11:29 PM, jack jack <jai...@gmail.com> wrote:
>>>>>
>>>>>> Stephen,Chris,
>>>>>>
>>>>>> I have also seen in the scmtools/repository section when i save the 
>>>>>> user name and password, password field get empty but its password is 
>>>>>> present in the database.
>>>>>>
>>>>>> Anonymous User Password: field in the LDAP section after saving the 
>>>>>> page the password field got empty.
>>>>>>
>>>>>> Could you please provide me workaround for this issues, So that i can 
>>>>>> proceed further.
>>>>>>
>>>>>> Thanks again for your response.
>>>>>>
>>>>>> Regards,
>>>>>> Jack
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Mon, Oct 3, 2011 at 7:22 PM, Stephen Gallagher <
>>>>>> ste...@gallagherhome.com> wrote:
>>>>>>
>>>>>>> On Mon, 2011-10-03 at 19:09 +0530, jack jack wrote:
>>>>>>> > I added following entries as suggested.
>>>>>>> >
>>>>>>> > Anonymous User Mask: uid=%s,CN=ldapquery,OU=Service
>>>>>>> > Accounts,OU=Exception Accounts,DC=na,DC=companyname,DC=com
>>>>>>>
>>>>>>> Do not use %s. It must be a specific user.
>>>>>>>
>>>>>>> > Anonymous User Password: <password>
>>>>>>> >
>>>>>>> > After saving the page the password field got empty.
>>>>>>> >
>>>>>>>
>>>>>>> That sounds like a bug to me. Christian?
>>>>>>>
>>>>>>> > Result: Not able to login using LDAP user: jackj
>>>>>>> >
>>>>>>> > Note: I am expecting once user jackj login into the RB it should 
>>>>>>> have
>>>>>>> > user id RB database. Please correct me if i am wrong
>>>>>>> >
>>>>>>> > In the reviewboard log i am getting error message as
>>>>>>> >
>>>>>>> > 2011-10-03 06:29:59,909 - WARNING - LDAP error: {'desc': "Can't
>>>>>>> > contact LDAP server"}
>>>>>>>
>>>>>>> "Can't contact LDAP server" usually means one of the following:
>>>>>>>
>>>>>>> 1) The LDAP URI is incorrect. Check for typos. Also, it could mean 
>>>>>>> that
>>>>>>> the LDAP server isn't running or listening on the specified port.
>>>>>>>
>>>>>>> 2) The LDAP server requires encryption and you aren't allowing it (if
>>>>>>> the port is SSL-enabled, you need to use ldaps:// for the URI, not
>>>>>>> ldap://. If it's not SSL-enabled, you may need to enable TLS)
>>>>>>>
>>>>>>> 3) If you were using encryption, it could be a bad certificate chain,
>>>>>>> and I don't think ReviewBoard allows you to manage this right now. It
>>>>>>> would require being able to specify a CA certificate for verification
>>>>>>> (or setting the validation to be permissive).
>>>>>>>
>>>>>>> --
>>>>>>> Want to help the Review Board project? Donate today at 
>>>>>>> http://www.reviewboard.org/donate/
>>>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>>>>> -~----------~----~----~----~------~----~------~--~---
>>>>>>> To unsubscribe from this group, send email to 
>>>>>>> reviewboard...@googlegroups.com
>>>>>>> For more options, visit this group at 
>>>>>>> http://groups.google.com/group/reviewboard?hl=en
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>  -- 
>>>> Want to help the Review Board project? Donate today at 
>>>> http://www.reviewboard.org/donate/
>>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>>> -~----------~----~----~----~------~----~------~--~---
>>>> To unsubscribe from this group, send email to 
>>>> reviewboard...@googlegroups.com
>>>> For more options, visit this group at 
>>>> http://groups.google.com/group/reviewboard?hl=en
>>>>
>>>
>>>  -- 
>>> Want to help the Review Board project? Donate today at 
>>> http://www.reviewboard.org/donate/
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> -~----------~----~----~----~------~----~------~--~---
>>> To unsubscribe from this group, send email to 
>>> reviewboard...@googlegroups.com
>>> For more options, visit this group at 
>>> http://groups.google.com/group/reviewboard?hl=en
>>>
>>
>>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to