On 04/30/2014 08:35 AM, Alexander Zhogov wrote:
> Hi Christian,
> I faced the same exception with a similar scenario. The "rb-site manage
> /path/to/site syncdb" command doesn't help.
> I am testing migration from the old system with Review Board 1.5 to a
> new CentOS 6.5 with Review Board 2.0 RC2:
> 1. Installed Review Board 2.0 RC2 on CentOS 6.5.
> 2. Restored mysql dump from the old system.
> 3. Run "rb-site upgrade </path/to/site>".
> Could you please help us to resolve the issue with migration?

For what it's worth, I tested a migration on Monday as follows:

1) Took a 'dumpdb' of a 1.7.25 server.
2) Installed a new 1.7.25 site on a new server
3) Imported the DB of the original
4) Tweaked the DB contents to point to the new path on disk (Relic of
OpenShift, didn't have exactly the same location)
5) Upgraded to 2.0 RC2 with easy_install
6) Ran rb-site upgrade

It worked cleanly for me.

I haven't tested trying to load the 1.7.25 DB directly into the 2.0
install, but this path worked.

Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to