Hi all,

I am using RBTools 0.6.1. While posting reviews I get this error

techopss-mbp-10:minted neeraj$ rbt post -g --target-groups=fulfillment -d 
-r23696

>>> RBTools 0.6.1

>>> Python 2.7.5 (default, Aug 25 2013, 00:04:04) 

[GCC 4.2.1 Compatible Apple LLVM 5.0 (clang-500.0.68)]

>>> Running on Darwin-13.1.0-x86_64-i386-64bit

>>> Home = /Users/neeraj

>>> Current directory = /Users/neeraj/Work/Minted/minted

>>> Checking for a Subversion repository...

>>> Running: svn info --non-interactive

>>> Command exited with rc 1: ['svn', 'info', '--non-interactive']

svn: E155007: '/Users/neeraj/Work/Minted/minted' is not a working copy

---

>>> Checking for a Git repository...

>>> Running: git rev-parse --git-dir

>>> Running: git config core.bare

>>> Running: git rev-parse --show-toplevel

>>> Running: git symbolic-ref -q HEAD

>>> Running: git svn info

>>> repository info: Path: https://svn.minted.com/svn, Base path: 
/minted/branches/release-printerapi, Supports changesets: False

>>> Making HTTP GET request to https://reviewboard.minted.com/api/

>>> Running: git rev-parse refs/heads/relprinterapi2

>>> Running: git merge-base 5c06f64988aaeb6716d89e8e009582ca8c0f7b82 trunk

>>> Running: git rev-parse e349309cd456b0b2a2265d2028d2468bb2325266

>>> Running: git status --porcelain --untracked-files=no

>>> Running: git diff --no-color --no-prefix -r -u 
e349309cd456b0b2a2265d2028d2468bb2325266..5c06f64988aaeb6716d89e8e009582ca8c0f7b82

>>> Running: git svn find-rev e349309cd456b0b2a2265d2028d2468bb2325266

>>> Running: git log --reverse --pretty=format:%s%n%n%b 
^e349309cd456b0b2a2265d2028d2468bb2325266 
5c06f64988aaeb6716d89e8e009582ca8c0f7b82

>>> Making HTTP GET request to 
https://reviewboard.minted.com/api/review-requests/23696/

>>> Making HTTP GET request to 
https://reviewboard.minted.com/api/review-requests/23696/diffs/

>>> Making HTTP POST request to 
https://reviewboard.minted.com/api/review-requests/23696/diffs/

>>> Got API Error 207 (HTTP code 400): The file was not found in the 
repository.

>>> Error data: {u'stat': u'fail', u'file': 
u'/minted/branches/release-printerapi/src/py/minted/logic/order/__init__.py', 
u'err': {u'msg': u'The file was not found in the repository.', u'code': 
207}, u'revision': u'45974'}

Traceback (most recent call last):

  File "/usr/local/bin/rbt", line 8, in <module>

    load_entry_point('RBTools==0.6.1', 'console_scripts', 'rbt')()

  File 
"/Library/Python/2.7/site-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/main.py",
 
line 134, in main

    command.run_from_argv([RB_MAIN, command_name] + args)

  File 
"/Library/Python/2.7/site-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/__init__.py",
 
line 416, in run_from_argv

    exit_code = self.main(*args) or 0

  File 
"/Library/Python/2.7/site-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/post.py",
 
line 784, in main

    submit_as=self.options.submit_as)

  File 
"/Library/Python/2.7/site-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/post.py",
 
line 543, in post_request

    error_msg.append(e.decode('utf-8') + u'\n')

AttributeError: 'BadRequestError' object has no attribute 'decode'

Also when I create a separate branch and try I get the same error. It 
created these zombie reviews with nothing in them. I have tried this after 
discarding all such reviews but still get the same error. Any idea whats 
wrong ?

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to