Hi!

We are currently on 1.7.14 and I am looking to upgrade us to 2.0.2.

I've tried 3 paths to upgrade (all following the RB instructions - upgrade 
RB, upgrade site, restart apache and memcached):

1.7.14 -> 2.0.2

1.7.14 -> 1.7.26 -> 2.0.2

1.7.14 -> 2.0.1 -> 2.0.2 

*I didn't go from 1.7.14 to 1.7.26 to 2.0.1 because of the schema change 
issue; figured it was probably not a good idea. *

The upgrade seems to be successful each time. However, the moment I try to 
go to the site, I get the following error:



*Something broke! (Error 500)*

*It appears something broke when you tried to go to here. This is either a 
bug in Review Board or a server configuration error. Please report this to 
your administrator."*


I tried looking at the server log but there was nothing there (last entry 
was review related). I deleted the old log to see if one would get created, 
but no joy. Not sure how to debug this.

Has anyone had this issue, and any ideas what I could to upgrade 
successfully?

The rb-site upgrade output for path 1 (1.7.14 -> 2.0.2) is below:

------------- <begin log output> -----------

Creating tables ...
Upgrading Review Board from 1.7.14 to 2.0.2
There are unapplied evolutions for auth.
There are unapplied evolutions for contenttypes.
There are unapplied evolutions for accounts.
There are unapplied evolutions for attachments.
There are unapplied evolutions for changedescs.
There are unapplied evolutions for diffviewer.
There are unapplied evolutions for hostingsvcs.
There are unapplied evolutions for reviews.
There are unapplied evolutions for scmtools.
There are unapplied evolutions for site.
Adding baseline version for new models
Project signature has changed - an evolution is required
Installing custom SQL ...
Installing indexes ...
Installed 0 object(s) from 0 fixture(s)
Evolution successful.
------------- <end log output> -----------

Resetting in-database caches
Upgrade complete!



-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to