Hi Michael,

How did you install Review Board? This is what I’d expect to see if you have a 
production install without having your web server handling static/ properly. 
Basically, Review Board is not expected to handle static/ (nor should it) 
unless it’s a development install straight out of the source tree.

Christian

-- 
Christian Hammond - christ...@beanbaginc.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com

On July 7, 2014 at 11:06:38 AM, Michael Kopp (michael.f.k...@googlemail.com) 
wrote:

Hi,


I've been trying to set up review-board on a lighttpd-server (v1.4.35) under 
arch linux.  I managed to set it up to display something, but unfortunately all 
the static data such as css, images and js are not loaded.  In the logs I see 
that they are not found.  Attached you can find many config files and some 
logs; `ls' holds the directory listings.  If I try to enter a file, that got a 
404-reply, directly as url, for example
http://virtualarch/rbex3/static/lib/js/jquery-1.8.2.min.js
(my server is called virtualarch, the installation is under /srv/http/rbex3, 
made by rb-site install) I get (with DEBUG=True [the situation does not change 
if I use DEBUG=False, apart from the nice 404-page.]) the following

Page not found (404)

Request Method: GET
Request URL:    http://virtualarch/rbex3/static/lib/js/jquery-1.8.2.min.js
Using the URLconf defined in djblets.urls.root, Django tried these URL 
patterns, in this order:

^rbex3/ ^admin/extensions/
^rbex3/ ^admin/
^rbex3/ ^jsi18n/ [name='js-catalog']
^rbex3/ ^account/
^rbex3/ ^s/(?P<local_site_name>[A-Za-z0-9\-_.]+)/
^rbex3/ ^$ [name='root']
^rbex3/ ^api/
^rbex3/ ^r/
^rbex3/ ^support/$ [name='support']
^rbex3/ ^users/(?P<username>[A-Za-z0-9@_\-\.'\+]+)/infobox/$ 
[name='user-infobox']
^rbex3/ ^r/$ [name='all-review-requests']
^rbex3/ ^dashboard/$ [name='dashboard']
^rbex3/ ^users/$ [name='all-users']
^rbex3/ ^users/(?P<username>[A-Za-z0-9@_\-\.'\+]+)/$ [name='user']
^rbex3/ ^groups/$ [name='all-groups']
^rbex3/ ^groups/(?P<name>[A-Za-z0-9_-]+)/$ [name='group']
^rbex3/ ^groups/(?P<name>[A-Za-z0-9_-]+)/members/$ [name='group-members']
^rbex3/ ^repos/(?P<repo_id>\d+)/
The current URL, rbex3/static/lib/js/jquery-1.8.2.min.js, didn't match any of 
these.

You're seeing this error because you have DEBUG = True in your Django settings 
file. Change that to False, and Django will display a standard 404 page. 



To me it looks like the request gets redirected to django although it is a 
normal file request.  So this is probably an issue with the 
url-rewriting/aliasing settings?

Can you please help me to solve this issue or give me some pointers on what do 
do?

Thank you.  Sincerely,
Michael Kopp

--
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
---
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to