> On July 7, 2014 at 11:06:38 AM, Michael Kopp (michael.f.k...@googlemail.com) 
> wrote:
>> I've been trying to set up review-board on a lighttpd-server (v1.4.35)
>> under arch linux.  I managed to set it up to display something, but
>> unfortunately all the static data such as css, images and js are not
>> loaded.  In the logs I see that they are not found.  Attached you can
>> find many config files and some logs; `ls' holds the directory
>> listings.  If I try to enter a file, that got a 404-reply, directly as
>> url, for example
>> http://virtualarch/rbex3/static/lib/js/jquery-1.8.2.min.js
>> (my server is called virtualarch, the installation is under
>> /srv/http/rbex3, made by rb-site install) I get (with DEBUG=True [the
>> situation does not change if I use DEBUG=False, apart from the nice
>> 404-page.]) the following
>> Page not found (404)
>> ...

On Mon, Jul 07, 2014 at 11:51:05AM -0700, Christian Hammond wrote:
> How did you install Review Board?
I installed it as an Arch-Linux AUR package -- basically,
    python2 setup.py install --root=/usr
was called with the sources from ReviewBoard-2.0.2.tar.gz.

> This is what I’d expect to see if you have a production install
> without having your web server handling static/ properly.

I'm sorry, but I don't quite get you.  How can I check, whether my web
server handels static/ properly?  Turning off the review-board .fcgi and
checking, whether all static conetnt is reachable?

> Basically, Review Board is not expected to handle static/ (nor should
> it) unless it’s a development install straight out of the source tree.

I don't get that either, sorry: You mean, if I had not installed the
package, but just used the built executable?

Thank you for your help and sorry for my -- probably stupid --


Michael Kopp <michael.f.k...@googlemail.com>

Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to