It doesn’t sound like anything but the metadata for Review Board 2.0.x was ever 
installed. No files were ever fetched.

Your mixing and matching of yum packages and easy_install packages is likely 
causing your problems. You also tried to install Review Board 2.0.x previously 
(given that it’s trying to find Whoosh), but now have mixed metadata for 2.0.x 
and 1.7.25 and 1.7.27.

Paramiko missing is another huge red flag. Sounds like your entire install is 
pretty much busted.

To begin fixing this, you will need to uninstall all the yum packages that 
affect Review Board (all the ones I mentioned before, plus Django, and maybe 
others.) Those are just going to cause problems, if you try to mix-and-match 
like this.

You then need to re-do an easy_install of ReviewBoard. Please save the entire 
log and attach it.

Christian

-- 
Christian Hammond - christ...@beanbaginc.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com

On July 30, 2014 at 1:09:14 PM, Michael Kovacs (dromin...@gmail.com) wrote:

OK so given the yum install is topped out at RB 1.7.25, Python at 2.6 and 
others accordingly, would the best way to be rpm -e on everything and 
reinstalling from scratch? Again, I have a snapshot of the running base system 
so reverting is not an issue when I get down a dead end..

OK so in the base system I have the following output:
 [root@Itt-D-Review logs]# locate egg | grep -i review
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info/PKG-INFO
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info/SOURCES.txt
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info/dependency_links.txt
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info/entry_points.txt
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info/not-zip-safe
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.25-py2.6.egg-info/top_level.txt

[root@Itt-D-Review logs]# locate egg | grep -i whoosh
[root@Itt-D-Review logs]#

[root@Itt-D-Review logs]# python -V
Python 2.6.6

[root@Itt-D-Review logs]# rpm -qa | grep -i review
ReviewBoard-1.7.25-1.el6.noarch
[root@Itt-D-Review logs]# rpm -qa | grep -i django
Django14-1.4.13-1.el6.noarch
python-django-evolution-0.6.9-4.el6.noarch
python-django-pipeline-1.2.24-2.el6.noarch


Now execute the easy_install -U on Djblets & django-evolu[root@Itt-D-Review 
logs]# easy_install -U django_evolution
Searching for django-evolution
Reading https://pypi.python.org/simple/django_evolution/
Reading http://code.google.com/p/django-evolution/
Reading http://downloads.reviewboard.org/releases/django-evolution/0.7/
Best match: django-evolution 0.7.3
Downloading 
http://downloads.reviewboard.org/releases/django-evolution/0.7/django_evolution-0.7.3-py2.6.egg
Processing django_evolution-0.7.3-py2.6.egg
removing '/usr/lib/python2.6/site-packages/django_evolution-0.7.3-py2.6.egg' 
(and everything under it)
creating /usr/lib/python2.6/site-packages/django_evolution-0.7.3-py2.6.egg
Extracting django_evolution-0.7.3-py2.6.egg to /usr/lib/python2.6/site-packages
django-evolution 0.7.3 is already the active version in easy-install.pth
Installed /usr/lib/python2.6/site-packages/django_evolution-0.7.3-py2.6.egg
Processing dependencies for django-evolution
Finished processing dependencies for django-evolution
tion:

Site is still available and up and running...

easy_install -U ReviewBoard==1.7.27

The upgrade log is rather lengthy and I will attach it if it will be helpful, 
but once it hit pcrypto we had warnings about definition locations:

Downloading 
https://pypi.python.org/packages/source/p/pycrypto/pycrypto-2.6.1.tar.gz#md5=55a61a054aa66812daf5161a0d5d7eda
Processing pycrypto-2.6.1.tar.gz
Writing /tmp/easy_install-tYbbrb/pycrypto-2.6.1/setup.cfg
Running pycrypto-2.6.1/setup.py -q bdist_egg --dist-dir 
/tmp/easy_install-tYbbrb/pycrypto-2.6.1/egg-dist-tmp-KXR7DR
warning: GMP or MPIR library not found; Not building Crypto.PublicKey._fastmath.
In file included from /usr/include/python2.6/pyconfig.h:6,
                 from /usr/include/python2.6/Python.h:8,
                 from src/MD2.c:31:
/usr/include/python2.6/pyconfig-64.h:1034:1: warning: "_POSIX_C_SOURCE" 
redefined
In file included from /usr/include/string.h:27,
                 from src/MD2.c:30:
/usr/include/features.h:162:1: warning: this is the location of the previous 
definition
......
/usr/include/python2.6/pyconfig-64.h:1043:1: warning: "_XOPEN_SOURCE" redefined
In file included from /usr/include/assert.h:37,
                 from src/_counter.c:25:
/usr/include/features.h:164:1: warning: this is the location of the previous 
definition
zip_safe flag not set; analyzing archive contents...
Adding pycrypto 2.6.1 to easy-install.pth file
Installed /usr/lib/python2.6/site-packages/pycrypto-2.6.1-py2.6-linux-x86_64.egg
Finished processing dependencies for ReviewBoard==1.7.27

rb-site upgrade /var/www/itt-d-review.abc.local   was successful

Restarted httpd successful

And we get the taking a nap message..

Running the same locate after an update gives:
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.27-py2.6.egg/EGG-INFO
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.27-py2.6.egg/reviewboard
/usr/lib/python2.6/site-packages/ReviewBoard-1.7.27-py2.6.egg/webtests
... and so on ...

There is still a 1.7.25 directory

But I still don't have a "whoosh" anywhere on the system??

The http error log shows
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99] mod_wsgi (pid=2492): 
Target WSGI script '/var/www/itt-d-review.aaa.local/htdocs/
reviewboard.wsgi' cannot be loaded as Python module.
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99] mod_wsgi (pid=2492): 
Exception occurred processing WSGI script 
'/var/www/itt-d-review.aaa.local/htdocs/reviewboard.wsgi'.
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99] Traceback (most recent 
call last):
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99]   File 
"/var/www/itt-d-review.aaa.local/htdocs/reviewboard.wsgi", line 3, in <mo
dule>
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99]     import 
pkg_resources
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99]   File 
"build/bdist.linux-x86_64/egg/pkg_resources.py", line 2876, in <module>
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99]   File 
"build/bdist.linux-x86_64/egg/pkg_resources.py", line 451, in _build_master
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99]   File 
"build/bdist.linux-x86_64/egg/pkg_resources.py", line 464, in 
_build_from_requireme
nts
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99]   File 
"build/bdist.linux-x86_64/egg/pkg_resources.py", line 639, in resolve
[Wed Jul 30 15:05:07 2014] [error] [client 10.200.33.99] DistributionNotFound: 
paramiko>=1.9.0

Nothing noted in reviewboard.log


If you wish I can up to 2.0.5 but my bet is the same issue will exist. If the 
next step is to reinstall from scratch I can do that too but might take a bit..





--
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
---
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to