OK so first off thanks for all the help getting things this far; we at 
least are up and running with RB itself! Now to tie it all together.

RBTools 0.6.2 
VisualSVN server v2.5.7 Standard Edition on Windows 2008R2
ReviewBoard 2.0.5 on Centos 6.5
Submitters will be running AnkhSVN integrated into their VS2010
Windows AD authentication for RB

Logic flow would be for the users to checkout a project, then when they 
check it in a diff is generated and sent to RB.So far I have been working 
with a test SVN on a Win8 station simply doing an svn co of the project, 
changing a file then svn ci. The VisualSVN server has a post-commit hook of 
the following to allow more extensive debugging:

call "%~dp0post-commit-run.cmd" %* > %1/hooks/post-commit.log 2>&1

The called file "post-commit-run.cmd" (which does have a lot of debugging 
buried in it) is:


SET Outfile = C:\drop
PATH=%PATH%;c:\Program Files (x86)\VisualSVN 
SET TEMPFILE=C:\drop\repo_diff.txt
SET DESCFILE=C:\drop\desc_chng.txt

echo %REPOS% >> c:\drop\devout.txt
path >> c:\drop\devout.txt
dir >> c:\drop\devout.txt
set >> c:\drop\devout.txt

svnlook diff -r %REV% %REPOS% > %TEMPFILE%
svnlook log -r %REV% %REPOS% > %DESCFILE%

PUSHD c:\Drop\co\NetworkConfigs
rbt post --server=http://itt-d-review.abc.local --username admin --password 
xxxxx --repository-type=svn 
--description-file="c:\drop\desc_chng.txt" -p -d
echo "%DESCFILE%" >> c:\drop\devout.txt
echo "%TEMPFILE%" >> c:\drop\devout.txt
more "%DESCFILE%" >> c:\drop\devout.txt
more "%TEMPFILE%" >> c:\drop\devout.txt


The various dump files show the proper data sitting in them, but 
the post-commit.log suggest that it cannot login to the repository to 
properly get information:


>>> Home = C:\Windows\ServiceProfiles\NetworkService\AppData\Roaming

>>> Current directory = c:\Drop\co\NetworkConfigs

>>> Checking for a Subversion repository...

>>> Running: svn info https://itt-d-cvs1.abc.local:8443/svn/NetworkConfigs 

>>> Command exited with rc 1: ['svn', 'info', 
'https://itt-d-cvs1.abc.local:8443/svn/NetworkConfigs', '--non-interactive']

svn: E170001: Unable to connect to a repository at URL 

svn: E170001: OPTIONS of 
'https://itt-d-cvs1.abc.local:8443/svn/NetworkConfigs': authorization 
failed: Could not authenticate to server: rejected Basic challenge (


ERROR: The provided repository type was not detected in the current 


I have also tried this with the parameter of  
"--repository-url=file:///data/SVNRoot/NetworkConfigs" without success. 
What is the error(s) here? Is there supposed to be auth params sent to 
connect to the SVN repository and if so how? The CMS file above is running 
on the same physical box as the SVN repo's are in, which is why they are 
reachable via file command...

This is so close but just needs a final tweak!

Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to