Hi , 

We are using  git as Version Control and we are using the  rbt tool for 
raising the review requests.

Version info
    RBTools 0.6.2
    git version

1. rbt post working fine for commits which are not pushed to remote.
2. But same fails when we try to raise review with already pushed code. 
Below are the various scenarios tried for this:
            1. rbt post --guess-summary --guess-description 
--tracking-branch origin/master --revision-range= 986fb30aae..58184a45a 
--server Myreviewboradserver
            2. rbt post R1..R2 --guess-summary --guess-description
            3. rbt post R1..R2 --guess-summary --guess-description 

In all above cases, it is failing by saying the error message: "Unable to 
find a Review Board server for this source code tree."

But on the same working copy, if we generate review before pushing the 
commits to remote, it worked as expected:
[srij@lccscm Demo]$ rbt post --guess-summary --guess-description --server 
http://xyz.com/ --debug
>>> RBTools 0.6.2
>>> Python 2.7.5 (default, Nov 12 2013, 16:18:42)
[GCC 4.8.2 20131017 (Red Hat 4.8.2-1)]
>>> Running on 
>>> Home = /home/srij
>>> Current directory = /home/srij/gitlab/Demo
>>> Checking for a Subversion repository...
>>> Running: svn info --non-interactive
>>> Command exited with rc 1: ['svn', 'info', '--non-interactive']
svn: E155007: '/home/srij/gitlab/Demo' is not a working copy
>>> Checking for a Git repository...
>>> Running: git rev-parse --git-dir
>>> Running: git config core.bare
>>> Running: git rev-parse --show-toplevel
>>> Running: git symbolic-ref -q HEAD
>>> Running: git config --get branch.master.merge
>>> Running: git config --get branch.master.remote
>>> Running: git config --get remote.origin.url
>>> repository info: Path: g...@xyz.abc/Demo.git, Base path: , Supports 
changesets: False
>>> Making HTTP GET request to http://xyz.abc/api/
>>> Making HTTP GET request to http://xyz.abc/api/info/
>>> Running: git rev-parse refs/heads/master
>>> Running: git merge-base 30126f8c24bc30bc7c4f68b03a913f16ce4ed007 
>>> Running: git rev-parse 8a727c5917e783ca82a22a2bdbb7021ea1a05469
>>> Running: git status --porcelain --untracked-files=no
>>> Running: git diff --no-color --full-index --ignore-submodules 
>>> Running: git log --reverse --pretty=format:%s%n%n%b 
>>> Making HTTP GET request to http://xyz.abc/api/review-requests/
>>> Making HTTP POST request to http://xyz.abc/api/review-requests/
>>> Making HTTP GET request to http://xyz.abc/api/review-requests/422/diffs/
>>> Making HTTP POST request to 
>>> Making HTTP GET request to http://xyz.abc/api/review-requests/422/draft/
>>> Making HTTP PUT request to http://xyz.abc/api/review-requests/422/draft/
Review request #422 posted.


What is wrong with this? How can I raise review request for already 
commited code?

Srinivas J


Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to