Thanks Christian, it is working, when I manually add additional /reviews in
the url.
I could able to login with admin.
But after login again, it is showing as page does not exist. When I add
additional /reviews in the dashboard, then it works.
http://localhost/reviews/reviews/dashboard/
Here I added additional reviews, then it worked.

How to fix this?

Thanks,
Jes



On Thu, Sep 4, 2014 at 2:31 AM, Christian Hammond <christ...@beanbaginc.com>
wrote:

> Just to try something.. What happens if you go to
> http://localhost/reviews/reviews/account/login/ ?
>
> - Christian
>
> --
> Christian Hammond - christ...@beanbaginc.com
> Review Board - http://www.reviewboard.org
> Beanbag, Inc. - http://www.beanbaginc.com
>
>
> On September 3, 2014 at 1:59:37 PM, Jes Kiran Ch (ch.jeski...@gmail.com)
> wrote:
> > Pls. find the screen details:
> >
> > Initial screen: localhost/reviews
> > This screen is captured in screen1. Here screen is displayed, but the
> tite
> > of the html is showing as 404 page does not exist. I attached screen shot
> > here.
> >
> > When register is pressed in the Initial screen, url is trying to point
> > localhost/reviews/account/register/
> > But it wont redirect to register screen, rather same initial screen would
> > be displayed. This screen is captured in screen2-register, which was
> > attached here.
> >
> > When login is pressed in Initial screen, url trying to point
> > localhost/reviews/account/login/?next=/
> > But it wont redirect to login screen, rather just displays the same
> initial
> > screen. This screen is captured in screen3-login, attached file here.
> >
> >
> > 000-default is the only file in sites-enabled.
> > /etc/apache2/sites-enabled# ls
> > 000-default
> >
> > Previously, when I copied to another .cfg file for ReviewBoard, Initial
> > screen is not displayed at all.
> > So I just copied ReviewBoard related config in the file 000-default
> itself.
> >
> > Contents of 000-default file:
> >
> >
> > # ServerAdmin webmaster@localhost
> >
> > # DocumentRoot /var/www
> > #
> > # Options FollowSymLinks
> > # AllowOverride None
> > #
> >
> > ServerName localhost
> > DocumentRoot "/var/www/html/reviews.localhost/htdocs"
> >
> > # Error handlers
> > ErrorDocument 500 /errordocs/500.html
> >
> > WSGIPassAuthorization on
> > WSGIScriptAlias "/reviews"
> > "/var/www/html/reviews.localhost/htdocs/reviewboard.wsgi"
> >
> >
> >
> > AllowOverride All
> > Options -Indexes +FollowSymLinks
> > Allow from all
> >
> >
> > # Prevent the server from processing or allowing the rendering of
> > # certain file types.
> >
> > SetHandler None
> > Options None
> >
> > AddType text/plain .html .htm .shtml .php .php3 .php4 .php5
> > .phps .asp
> > AddType text/plain .pl .py .fcgi .cgi .phtml .phtm .pht
> > .jsp .sh .rb
> >
> >
> > php_flag engine off
> >
> >
> >
> > # Alias static media requests to filesystem
> > Alias /reviews/media "/var/www/html/reviews.localhost/htdocs/media"
> > Alias /reviews/static
> > "/var/www/html/reviews.localhost/htdocs/static"
> > Alias /reviews/errordocs
> > "/var/www/html/reviews.localhost/htdocs/errordocs"
> > Alias /reviews/favicon.ico
> > "/var/www/html/reviews.localhost/htdocs/static/rb/images/favicon.png"
> >
> >
> >
> >
> >
> >
> > Pls. help
> > - Jes
> >
> >
> > On Thu, Sep 4, 2014 at 1:54 AM, Christian Hammond
> > wrote:
> >
> > > When you say the “main screen,” you mean the one saying “The page you
> were
> > > looking for does not exist” ? I’m afraid I still don’t have a good
> enough
> > > mental picture of exactly what you are seeing and what goes wrong.
> > >
> > > There’s enough working to show error pages and to show styles and
> images.
> > >
> > > If you click “Log in” or “Register,” do you still see a 404? What URLs
> > > does it try to go to?
> > >
> > > Are there any other files in the sites-enabled directory?
> > >
> > > Christian
> > >
> > > --
> > > Christian Hammond - christ...@beanbaginc.com
> > > Review Board - http://www.reviewboard.org
> > > Beanbag, Inc. - http://www.beanbaginc.com
> > >
> > > On September 3, 2014 at 1:13:43 PM, Jes Kiran Ch (
> ch.jeski...@gmail.com)
> > > wrote:
> > >
> > > Thanks for reply.
> > > No url is working. It just displays the main screen.
> > > Main screen url is hostname/reviews
> > > Even while displaying the main screen also it shows as 404 error but
> > > displays images. I am using default file in the apache sites-enabled
> > > directory.
> > > Thanks,
> > > Jes.
> > > On 4 Sep 2014 01:26, "Christian Hammond" wrote:
> > >
> > >> Hi,
> > >>
> > >> Sorry, been out the past week.
> > >>
> > >> I’m a little confused by what the actual problem is that you’re
> hitting.
> > >> Initially, with the first screenshot, I thought it was a static media
> > >> problem (since it didn’t look like there’s any styling on the page).
> The
> > >> second screenshot you provided shows that the static media is loading
> fine.
> > >>
> > >> Is it just that you’re getting a 404 error? If so, what’s the URL
> you’re
> > >> at? Is there any URL that works?
> > >>
> > >> - Christian
> > >>
> > >> --
> > >> Christian Hammond - christ...@beanbaginc.com
> > >> Review Board - http://www.reviewboard.org
> > >> Beanbag, Inc. - http://www.beanbaginc.com
> > >>
> > >> On September 3, 2014 at 12:52:45 PM, Jes Kiran Ch (
> ch.jeski...@gmail.com)
> > >> wrote:
> > >>
> > >> Any update?
> > >>
> > >> Thanks,
> > >> Jrd
> > >>
> > >>
> > >> On Mon, Sep 1, 2014 at 1:51 PM, Jes Kiran Ch
> > >> wrote:
> > >>
> > >>> Could you pls. provide resolution for this?
> > >>> I uploaded html file.
> > >>> Our project is stuck with this issue.
> > >>>
> > >>> Thanks for your help.
> > >>>
> > >>> - Jes
> > >>>
> > >>>
> > >>> On Wed, Aug 27, 2014 at 8:06 PM, Jes Kiran Ch
> > >>> wrote:
> > >>>
> > >>>> Thanks for quick reply.
> > >>>> Pls, find html file.
> > >>>>
> > >>>> Thanks,
> > >>>> Jes.
> > >>>>
> > >>>>
> > >>>>
> > >>>> On Wed, Aug 27, 2014 at 3:47 PM, Christian Hammond <
> > >>>> christ...@beanbaginc.com> wrote:
> > >>>>
> > >>>>> I’ll need the HTML file sent by the server, not the screenshot.
> > >>>>>
> > >>>>> It’s 3AM where I am, so there won’t be a response until tomorrow,
> my
> > >>>>> time.
> > >>>>>
> > >>>>> Christian
> > >>>>>
> > >>>>> --
> > >>>>> Christian Hammond - christ...@beanbaginc.com
> > >>>>> Review Board - http://www.reviewboard.org
> > >>>>> Beanbag, Inc. - http://www.beanbaginc.com
> > >>>>>
> > >>>>> On August 27, 2014 at 2:26:25 AM, Jes Kiran Ch (
> ch.jeski...@gmail.com)
> > >>>>> wrote:
> > >>>>>
> > >>>>> Thanks for response.
> > >>>>>
> > >>>>> Pls. find the files in the directory
> > >>>>> /var/www/html/reviews.localhost/htdocs/static/rb/css
> > >>>>>
> > >>>>> /var/www/html/reviews.localhost/htdocs/static/rb/css# ls
> > >>>>> admin.af1e57e50520.css common.min.css
> > >>>>> dndUploader.fead88c69081.css js-tests.css
> > >>>>> reviews.css
> > >>>>> admin.cded2d29a0a5.less common.min.e6e71be831db.css
> > >>>>> dndUploader.less js-tests.less
> > >>>>> reviews.less
> > >>>>> admin.css dashboard.2004d713bc71.less
> > >>>>> icons.541184cf811c.less js-tests.min.70d6ede4e69e.css
> > >>>>> reviews.min.css
> > >>>>> admin-dashboard.02fc1c471be8.css dashboard.612141c17ec3.css
> > >>>>> icons.ad3434a7f03d.css js-tests.min.css
> > >>>>> reviews.min.f35ccb97b383.css
> > >>>>> admin-dashboard.0b188b58f63d.less dashboard.css
> > >>>>> icons.css newReviewRequest.553ee0e0dafe.css
> > >>>>> search.0553e42c0d00.less
> > >>>>> admin-dashboard.css dashboard.less
> > >>>>> icons.less newReviewRequest.925a5336bb65.less
> > >>>>> search.47a5f4d644fe.css
> > >>>>> admin-dashboard.less defs.5c980c04bb20.less
> > >>>>> ie_hacks.css newReviewRequest.css
> > >>>>> search.css
> > >>>>> admin.less defs.less
> > >>>>> ie_hacks.e31a795a9b81.css newReviewRequest.less
> > >>>>> search.less
> > >>>>> admin.min.ce27d11fc6d3.css diffviewer.3b39d57bd385.less
> > >>>>> image-review-ui.13cbfc73450a.css
> newReviewRequest.min.553ee0e0dafe.css
> > >>>>> syntax.ce7aee4d975e.css
> > >>>>> admin.min.css diffviewer.ce7c7fb93260.css
> > >>>>> image-review-ui.6807547f650b.less newReviewRequest.min.css
> > >>>>> syntax.css
> > >>>>> common.2d8bc5eb5c27.css diffviewer.css
> > >>>>> image-review-ui.css retina.c7f70aa1f6ba.less
> > >>>>> text-review-ui.4c115bbd5a47.less
> > >>>>> common.39370f10a01e.less diffviewer.less
> > >>>>> image-review-ui.less retina.less
> > >>>>> text-review-ui.c542ac9fff25.css
> > >>>>> common.css dndUploader.css
> > >>>>> js-tests.70d6ede4e69e.css reviews.50b65e56a95b.css
> > >>>>> text-review-ui.css
> > >>>>> common.less dndUploader.e2e756c09d05.less
> > >>>>> js-tests.9844a908a7ed.less reviews.866218f8f970.less
> > >>>>> text-review-ui.less
> > >>>>>
> > >>>>> Attached page screen shot.
> > >>>>>
> > >>>>> Pls. help
> > >>>>>
> > >>>>>
> > >>>>> On Wed, Aug 27, 2014 at 3:55 AM, Christian Hammond <
> > >>>>> christ...@beanbaginc.com> wrote:
> > >>>>>
> > >>>>>> You shouldn’t have shared your password or SECRET_KEY with us.
> > >>>>>> You’ll need to change those.
> > >>>>>>
> > >>>>>> It looks like the media files just aren’t being served. Can you
> show
> > >>>>>> me two things:
> > >>>>>>
> > >>>>>> 1) A directory listing of
> > >>>>>> /var/www/html/reviews.localhost/htdocs/static/rb/css/
> > >>>>>>
> > >>>>>> 2) Attach the HTML for the page in the screenshot.
> > >>>>>>
> > >>>>>> Christian
> > >>>>>>
> > >>>>>> --
> > >>>>>> Christian Hammond - christ...@beanbaginc.com
> > >>>>>> Review Board - http://www.reviewboard.org
> > >>>>>> Beanbag, Inc. - http://www.beanbaginc.com
> > >>>>>>
> > >>>>>> On August 26, 2014 at 12:19:30 PM, ch.jeski...@gmail.com (
> > >>>>>> ch.jeski...@gmail.com) wrote:
> > >>>>>>
> > >>>>>> 000-default file:
> > >>>>>>
> > >>>>>> ServerName localhost
> > >>>>>> DocumentRoot "/var/www/html/reviews.localhost/htdocs"
> > >>>>>>
> > >>>>>> # Error handlers
> > >>>>>> ErrorDocument 500 /errordocs/500.html
> > >>>>>>
> > >>>>>> WSGIPassAuthorization On
> > >>>>>> WSGIScriptAlias "/reviews"
> > >>>>>> "/var/www/html/reviews.localhost/htdocs/reviewboard.wsgi/reviews/"
> > >>>>>>
> > >>>>>>
> > >>>>>>
> > >>>>>> AllowOverride All
> > >>>>>> Options -Indexes +FollowSymLinks
> > >>>>>> Allow from all
> > >>>>>>
> > >>>>>>
> > >>>>>> # Prevent the server from processing or allowing the
> > >>>>>> rendering of
> > >>>>>> # certain file types.
> > >>>>>>
> > >>>>>> SetHandler None
> > >>>>>> Options None
> > >>>>>>
> > >>>>>> AddType text/plain .html .htm .shtml .php .php3 .php4
> > >>>>>> .php5 .phps .asp
> > >>>>>> AddType text/plain .pl .py .fcgi .cgi .phtml .phtm
> > >>>>>> .pht .jsp .sh .rb
> > >>>>>>
> > >>>>>>
> > >>>>>> php_flag engine off
> > >>>>>>
> > >>>>>>
> > >>>>>>
> > >>>>>> # Alias static media requests to filesystem
> > >>>>>> Alias /reviews/media
> > >>>>>> "/var/www/html/reviews.localhost/htdocs/media"
> > >>>>>> Alias /reviews/static
> > >>>>>> "/var/www/html/reviews.localhost/htdocs/static"
> > >>>>>> Alias /reviews/errordocs
> > >>>>>> "/var/www/html/reviews.localhost/htdocs/errordocs"
> > >>>>>> Alias /reviews/favicon.ico
> > >>>>>>
> "/var/www/html/reviews.localhost/htdocs/static/rb/images/favicon.png"
> > >>>>>>
> > >>>>>> settings_local.py file:
> > >>>>>>
> > >>>>>> DATABASES = {
> > >>>>>> 'default': {
> > >>>>>> 'ENGINE': 'django.db.backends.mysql',
> > >>>>>> 'NAME': 'reviewboard',
> > >>>>>> 'USER': 'root',
> > >>>>>> 'PASSWORD': 'hacmp',
> > >>>>>> 'HOST': 'localhost',
> > >>>>>> 'PORT': '',
> > >>>>>> },
> > >>>>>> }
> > >>>>>>
> > >>>>>> # Unique secret key. Don't share this with anybody.
> > >>>>>> SECRET_KEY = '3r8&_d6(gis^65o1iv$h58a@iro)61&o&x$bg00698+b7fl-l%'
> > >>>>>>
> > >>>>>> # Cache backend settings.
> > >>>>>> CACHES = {
> > >>>>>> 'default': {
> > >>>>>> 'BACKEND':
> > >>>>>> 'django.core.cache.backends.memcached.MemcachedCache',
> > >>>>>> 'LOCATION': 'localhost:11211',
> > >>>>>> },
> > >>>>>> }
> > >>>>>>
> > >>>>>> # Extra site information.
> > >>>>>> SITE_ID = 1
> > >>>>>> SITE_ROOT = '/reviews/'
> > >>>>>> FORCE_SCRIPT_NAME = ''
> > >>>>>> DEBUG = False
> > >>>>>>
> > >>>>>> Pls. help
> > >>>>>>
> > >>>>>>
> > >>>>>> On Wednesday, August 27, 2014 12:17:44 AM UTC+5:30,
> > >>>>>> ch.je...@gmail.com wrote:
> > >>>>>>>
> > >>>>>>> Installed ReviewBoard 2.0.6 with mysql and apache2.
> > >>>>>>> when reviewboard conf file is copied to
> /etc/apache2/sites-available
> > >>>>>>> and a symbolic link/etc/apache2/sites-enabled had not showing
> the screen
> > >>>>>>> with mozilla.
> > >>>>>>> Henceappened reviewboard conf content to default apache conf
> > >>>>>>> file(000-default).
> > >>>>>>> IT showed a screen but not moving to register/login screen. Pls.
> help
> > >>>>>>>
> > >>>>>>>
> > >>>>>>>
> > >>>>>>> --
> > >>>>>> Get the Review Board Power Pack at
> > >>>>>> http://www.reviewboard.org/powerpack/
> > >>>>>> ---
> > >>>>>> Sign up for Review Board hosting at RBCommons:
> https://rbcommons.com/
> > >>>>>> ---
> > >>>>>> Happy user? Let us know at http://www.reviewboard.org/users/
> > >>>>>> ---
> > >>>>>> You received this message because you are subscribed to the Google
> > >>>>>> Groups "reviewboard" group.
> > >>>>>> To unsubscribe from this group and stop receiving emails from it,
> > >>>>>> send an email to reviewboard+unsubscr...@googlegroups.com.
> > >>>>>> For more options, visit https://groups.google.com/d/optout.
> > >>>>>> ------------------------------
> > >>>>>>
> > >>>>>>
> > >>>>> --
> > >>>>> Get the Review Board Power Pack at
> > >>>>> http://www.reviewboard.org/powerpack/
> > >>>>> ---
> > >>>>> Sign up for Review Board hosting at RBCommons:
> https://rbcommons.com/
> > >>>>> ---
> > >>>>> Happy user? Let us know at http://www.reviewboard.org/users/
> > >>>>> ---
> > >>>>> You received this message because you are subscribed to the Google
> > >>>>> Groups "reviewboard" group.
> > >>>>> To unsubscribe from this group and stop receiving emails from it,
> send
> > >>>>> an email to reviewboard+unsubscr...@googlegroups.com.
> > >>>>> For more options, visit https://groups.google.com/d/optout.
> > >>>>> ------------------------------
> > >>>>>
> > >>>>>
> > >>>>
> > >>>
> > >> --
> > >> Get the Review Board Power Pack at
> http://www.reviewboard.org/powerpack/
> > >> ---
> > >> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> > >> ---
> > >> Happy user? Let us know at http://www.reviewboard.org/users/
> > >> ---
> > >> You received this message because you are subscribed to the Google
> Groups
> > >> "reviewboard" group.
> > >> To unsubscribe from this group and stop receiving emails from it,
> send an
> > >> email to reviewboard+unsubscr...@googlegroups.com.
> > >> For more options, visit https://groups.google.com/d/optout.
> > >>
> > >> --
> > > Get the Review Board Power Pack at
> http://www.reviewboard.org/powerpack/
> > > ---
> > > Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> > > ---
> > > Happy user? Let us know at http://www.reviewboard.org/users/
> > > ---
> > > You received this message because you are subscribed to the Google
> Groups
> > > "reviewboard" group.
> > > To unsubscribe from this group and stop receiving emails from it, send
> an
> > > email to reviewboard+unsubscr...@googlegroups.com.
> > > For more options, visit https://groups.google.com/d/optout.
> > >
> > >
> >
> > --
> > Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> > ---
> > Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> > ---
> > Happy user? Let us know at http://www.reviewboard.org/users/
> > ---
> > You received this message because you are subscribed to the Google
> Groups "reviewboard"
> > group.
> > To unsubscribe from this group and stop receiving emails from it, send
> an email to reviewboard+unsubscr...@googlegroups.com.
> > For more options, visit https://groups.google.com/d/optout.
> >
>
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to