Hi Eugene,

Glad you figured that out. I think we need to do some validation when
creating Subversion repositories to ensure they're always pointing to the
root..

- Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com


On Tue, Sep 2, 2014 at 11:17 AM, Eugene <eugene.m...@gmail.com> wrote:

> Ok, figured that out:
>
> ReviewBoard's Subversion repository configuration must point to the root
> of the repository(see also
> https://code.google.com/p/reviewboard/issues/detail?id=1969)
>
> in my case it changing
> https://fs.company.com/svn-proj/a/b/c/d
>
> to
> https://fs.company.com/svn-proj
>
> fixed the issue
>
> On Friday, August 29, 2014 3:25:23 PM UTC-4, Eugene wrote:
>>
>> Read few posts about API Error 207, but still can't figure the problem
>> with my setup (this is a completely new RB installation for my company).
>> In the log below I replaced real path and file names with \a\b\c\d\e\f ...
>> I also verified that all svn commands shown in debug log work ok.
>>
>> C:\svn-proj\a\b\c\d>rbt post -d --username <name> --password <pass>
>> --server https://reviewboard.company.com/ --repository Foo -I
>> e\f\myfile.h
>> >>> RBTools 0.6.2
>> >>> Python 2.7.7 (default, Jun  1 2014, 14:21:57) [MSC v.1500 64 bit
>> (AMD64)]
>> >>> Running on Windows-7-6.1.7601-SP1
>> >>> Home = C:\Users\Eugene\AppData\Roaming
>> >>> Current directory = C:\svn-proj\a\b\c\d
>> >>> Checking for a Subversion repository...
>> >>> Running: svn info --non-interactive
>> >>> Running: diff --version
>> >>> repository info: Path: https://fs.company.com/svn-proj, Base path:
>> /a/b/c/d, Supports changesets: False
>> >>> Making HTTP GET request to https://reviewboard.company.com/api/
>> >>> Running: svn info --non-interactive
>> >>> Running: diff --version
>> >>> repository info: Path: https://fs.company.com/svn-proj, Base path:
>> /a/b/c/d, Supports changesets: False
>> >>> Running: svn status --ignore-externals
>> >>> Running: svn diff --diff-cmd=diff --notice-ancestry -r BASE
>> e\f\myfile.h
>> >>> Running: svn info e/f/myfile.h
>> >>> Running: svn info e/f
>> >>> Running: svn info e
>> >>> Running: svn diff --diff-cmd=diff --notice-ancestry -r BASE
>> e\f\myfile.h --no-diff-deleted
>> >>> Running: svn info e/f/myfile.h
>> >>> Running: svn info e/f/myfile.h
>> >>> Running: svn info e/f/myfile.h
>> >>> Making HTTP GET request to https://reviewboard.company.
>> com/api/review-requests/
>> >>> Making HTTP POST request to https://reviewboard.company.
>> com/api/review-requests/
>> >>> Making HTTP GET request to https://reviewboard.company.
>> com/api/review-requests/5/diffs/
>> >>> Making HTTP POST request to https://reviewboard.company.
>> com/api/review-requests/5/diffs/
>> >>> Got API Error 207 (HTTP code 400): The file was not found in the
>> repository.
>> >>> Error data: {u'stat': u'fail', u'file': u'/a/b/c/d/e/f/myfile.h',
>> u'err': {u'msg': u'The file was not found in the repository.', u'code':
>>  207}, u'revision': u'36504'}
>> Traceback (most recent call last):
>>   File "C:\Python27\Scripts\rbt-script.py", line 9, in <module>
>>     load_entry_point('RBTools==0.6.2', 'console_scripts', 'rbt')()
>>   File 
>> "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\main.py",
>> line 134, in main
>>     command.run_from_argv([RB_MAIN, command_name] + args)
>>   File "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.
>> egg\rbtools\commands\__init__.py", line 416, in run_from_argv
>>     exit_code = self.main(*args) or 0
>>   File 
>> "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\post.py",
>> line 784, in main
>>     submit_as=self.options.submit_as)
>>   File 
>> "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\post.py",
>> line 551, in post_request
>>     raise CommandError(u'\n'.join(error_msg))
>> rbtools.commands.CommandError: Error uploading diff
>>
>> The file was not found in the repository. (HTTP 400, API Error 207)
>>
>> Your review request still exists, but the diff is not attached.
>>
>> https://reviewboard.company.com/r/5/
>>
>> Repository Foo has the following URL (in the admin setup):
>> https://fs.company.com/svn-proj/a/b/c/d
>> I think on server side PySVN is used: based on server log:
>> 18:44:59 INFO
>>
>>  - Using reviewboard.scmtools.svn.pysvn backend for SVN
>>
>>
>> Pls advise what else could be missing in the setup?
>>
>  --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to