Hi,

Well, the 404 should be handled in Chrome itself as an error. It *is* valid to 
have a 404 from that API call (it just means there's no draft yet), and then we 
handle the failure response from it, but it sounds as if it's going down the 
wrong path.

I'm also using Chrome and aren't hitting it. What version are you running? Any 
extensions?

Christian

-- 
Christian Hammond - christ...@beanbaginc.com
Review Board - https://www.reviewboard.org 
Beanbag, Inc. - https://www.beanbaginc.com


On September 20, 2014 at 3:36:43 PM, Zongwei (l.zong...@gmail.com) wrote:
> Thanks for fixing the apply error; I don't see it anymore in v2.07. The
> extra_data error is still there though, as you mentioned. I looked in
> Firefox, and the same AJAX call is there that 404's, but it still works
> correctly. I think your hunch might be right that Chrome (at least the
> version I'm using) is treating the 404 call as a success. Where's the code
> that attempts to parse that particular response (I'm not familiar with the
> repo structure, sorry)?
> 
> On Saturday, September 20, 2014 3:18:20 PM UTC-7, Zongwei wrote:
> >
> > I was using Chrome v37.0.2062.120 m. I tried with Firefox, and RB v2.0.6
> > works without any issues. After making one comment on a diff in Firefox, I
> > opened up the same diff in Chrome and then was able to add additional
> > comments without issue. It looks like the issue is only when trying to load
> > the "Edit Review/Publish" bar at the top for the first time. I'll try RB
> > v2.07 with Chrome and see if it fixes it!
> >
> > On Saturday, September 20, 2014 11:10:22 AM UTC-7, Christian Hammond wrote:
> >>
> >> Hi,
> >>
> >> Thanks for the detailed info. Sorry for the late response.
> >>
> >> I'm really unsure as to why that error involving 'extra_data' is
> >> occurring. I can't reproduce it. It *looks* as if the browser is
> >> interpreting the 404 as a success, resulting in us trying to parse the
> >> payload. That should not be happening. Can you try with other browsers?
> >> (Which browser are you using?)
> >>
> >> The 'apply' error though is fixed in 2.0.7.
> >>
> >> Christian
> >>
> >> --
> >> Christian Hammond - chri...@beanbaginc.com
> >> Review Board - https://www.reviewboard.org
> >> Beanbag, Inc. - https://www.beanbaginc.com
> >>
> >>
> >> On September 20, 2014 at 8:31:36 AM, Zongwei (l.zo...@gmail.com) wrote:
> >> > Any luck? Anything else you need from my end?
> >> >
> >> > On Saturday, September 13, 2014 9:32:43 PM UTC-7, Zongwei wrote:
> >> > >
> >> > > Thanks for the quick response! Here's everything you requested.
> >> > >
> >> > > On Saturday, September 13, 2014 2:10:37 PM UTC-7, Christian Hammond
> >> wrote:
> >> > >>
> >> > >> Hi,
> >> > >>
> >> > >> Can you show the request/response payloads from the Network tab for
> >> the
> >> > >> most recent API request(s)?
> >> > >>
> >> > >> Can you also click the link for the base.min.*.js on the right of
> >> the
> >> > >> error, click the "{}" button at the bottom of the window, then go
> >> back to
> >> > >> the error, click again, and screenshot what line is actually making
> >> that
> >> > >> call? Seeing the stack trace would also help.
> >> > >>
> >> > >> Christian
> >> > >>
> >> > >> --
> >> > >> Christian Hammond - chri...@beanbaginc.com
> >> > >> Review Board - https://www.reviewboard.org
> >> > >> Beanbag, Inc. - https://www.beanbaginc.com
> >> > >>
> >> > >>
> >> > >> On September 13, 2014 at 1:07:30 PM, Zongwei (l.zo...@gmail.com)
> >> wrote:
> >> > >> > I have ReviewBoard v2.0.6 installed on an Ubuntu 12.04.3 LTS
> >> server.
> >> > >> > Whenever I try to comment on a diff in a review, I get the JS
> >> error
> >> > >> seen in
> >> > >> > the screenshot. I can post the comment without issue, but then the
> >> top
> >> > >> bar
> >> > >> > that normally says "Edit Review" and "Publish" stays in the
> >> loading
> >> > >> state
> >> > >> > and never appears. As a result, I can't post any reviews. Any
> >> > >> suggestions?
> >> > >> >
> >> > >> > --
> >> > >> > Get the Review Board Power Pack at
> >> > >> http://www.reviewboard.org/powerpack/
> >> > >> > ---
> >> > >> > Sign up for Review Board hosting at RBCommons:
> >> https://rbcommons.com/
> >> > >> > ---
> >> > >> > Happy user? Let us know at http://www.reviewboard.org/users/
> >> > >> > ---
> >> > >> > You received this message because you are subscribed to the Google
> >> > >> Groups "reviewboard"
> >> > >> > group.
> >> > >> > To unsubscribe from this group and stop receiving emails from it,
> >> send
> >> > >> an email to reviewboard...@googlegroups.com.
> >> > >> > For more options, visit https://groups.google.com/d/optout.
> >> > >> >
> >> > >>
> >> > >>
> >>
> >>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to