Realized it is indeed a config error ... should've indicated
http://172.30.166.36/reviews instead of http://172.30.166.36.  Now it
progressed a bit but stopped at :

C:\Users\jsyjuco\Documents\source_code\s21patch\application>rbt setup-repo
-d
>>> RBTools 0.6.2
>>> Python 2.7.8 (default, Jun 30 2014, 16:03:49) [MSC v.1500 32 bit
(Intel)]
>>> Running on Windows-7-6.1.7601-SP1
>>> Home = C:\Users\jsyjuco\AppData\Roaming
>>> Current directory =
C:\Users\jsyjuco\Documents\source_code\s21patch\applicat
ion
Enter the Review Board server URL: http://172.30.166.36/reviews
>>> Checking for a Subversion repository...
>>> Running: svn info --non-interactive
>>> Running: diff --version
>>> repository info: Path: svn://svn.xxx.com/ecom, Base path:
/esa/branches/<branchname>/application, Supports changesets: False
>>> Making HTTP GET request to http://172.30.166.36/reviews/api/
>>> Making HTTP GET request to http://172.30.166.36/reviews/api/info/
>>> Making HTTP GET request to
http://172.30.166.36/reviews/api/repositories/
No Subversion repository found or selected for http://172.30.166.36/reviews.
.re
viewboardrc not created.

I've seen similar posts related to this one ...hope one of them works :)

thanks for the quick response Christian

Regards,
Joseph

On Fri, Sep 19, 2014 at 12:02 AM, Christian Hammond <
christ...@beanbaginc.com> wrote:

> That does look to be a configuration issue. What URL do you use to reach
> your Review Board site?
>
> Christian
>
> --
> Christian Hammond - christ...@beanbaginc.com
> Review Board - https://www.reviewboard.org
> Beanbag, Inc. - https://www.beanbaginc.com
>
>
> On September 18, 2014 at 9:00:52 AM, Joseph Syjuco (kernelpa...@gmail.com)
> wrote:
> > Hi all,
> > Need help in setting up/ connecting my reviewboard installation with my
> > repository (svn). As per documentation, the recommended approach is to
> > execute a "rbt setup-repo" inside my checkout folder. I did this
> expecting
> > a .reviewboardrc but got an error instead :
> >
> > rbt setup-repo -d
> > >>> RBTools 0.6.2
> > >>> Python 2.7.8 (default, Jun 30 2014, 16:03:49) [MSC v.1500 32 bit
> > (Intel)]
> > >>> Running on Windows-7-6.1.7601-SP1
> > >>> Home = C:\Users\jsyjuco\AppData\Roaming
> > >>> Current directory =
> C:\Users\jsyjuco\Documents\source_code\xxx\applicat
> > ion
> > Enter the Review Board server URL: http://172.30.166.36
> > >>> Checking for a Subversion repository...
> > >>> Running: svn info --non-interactive
> > >>> Running: diff --version
> > >>> repository info: Path: svn://svn.xxx.com/yyy, Base path:
> /xxx/branches/
> > branchname/application, Supports changesets: False
> > >>> Making HTTP GET request to http://172.30.166.36/api/
> > >>> Got HTTP error: 404:
> >
> >
> >
> >
> Not Found
>
>
> >
> The requested URL /api/ was not found on this server.
>
>
> >
>
> >
> Apache/2.2.15 (CentOS) Server at 172.30.166.36 Port 80
>
> >
> >
> > Traceback (most recent call last):
> > File "C:\Python27\Scripts\rbt-script.py", line 9, in
> > load_entry_point('RBTools==0.6.2', 'console_scripts', 'rbt')()
> > File
> > "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\m
> > ain.py", line 134, in main
> > command.run_from_argv([RB_MAIN, command_name] + args)
> > File
> > "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\_
> > _init__.py", line 416, in run_from_argv
> > exit_code = self.main(*args) or 0
> > File
> > "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\s
> > etup_repo.py", line 106, in main
> > api_client, api_root = self.get_api(server)
> > File
> > "C:\Python27\lib\site-packages\rbtools-0.6.2-py2.7.egg\rbtools\commands\_
> > _init__.py", line 563, in get_api
> > raise CommandError("Unexpected API Error: %s" % e)
> > rbtools.commands.CommandError: Unexpected API Error: HTTP 404
> >
> >
> > At least if I were to read the logs, it looks like it is expecting the
> > /api/ but its not there ... not sure if I missed a step in the creation
> of
> > the repository but Im at a dead end on how I can resolve this. I'd
> > appreciate any tips/ suggestions on how I can address this issue.
> >
> > --
> > Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> > ---
> > Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> > ---
> > Happy user? Let us know at http://www.reviewboard.org/users/
> > ---
> > You received this message because you are subscribed to the Google
> Groups "reviewboard"
> > group.
> > To unsubscribe from this group and stop receiving emails from it, send
> an email to reviewboard+unsubscr...@googlegroups.com.
> > For more options, visit https://groups.google.com/d/optout.
> >
>
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to