Sorry for the confusion. I meant the "new" file is already committed to the 
repository.

(1) I am on the origin/master branch for testing purpose.
(2) git diff origin/master does not show anything.
(3) git log -p -2 shows (which is when we first commit the new file and 
push it back to the origin/master):

[nlo@rb testrepo3]$ git log -p -2
commit 5d095244494ee46260897bc770bf3aa0eb3f9a12
Author: root
Date:   Mon Dec 15 11:43:56 2014 -0500

    testing

diff --git a/hello.c b/hello.c
new file mode 100644
index 0000000..dc16a91
--- /dev/null
+++ b/hello.c
@@ -0,0 +1,6 @@
+#include <stdio.h>
+
+int main(){
+  fprintf(stderr, "Hello World\n");
+  return 0;
+}

Thank you very much

Norman


On Monday, December 15, 2014 4:40:31 PM UTC-5, Christian Hammond wrote:
>
> It's going to do a diff. We don't upload whole files, and we only work 
> with files that are already committed to the repository. 
>
> Can you tell me the following: 
>
> 1) What branch are you on when you post this? 
>
> 2) Does a 'git diff origin/master..HEAD' show changes to that file 
> (hello.c)? 
>
> 3) Is there a specific commit that contains the changes to that file that 
> you want to put up for review? 
>
> Christian 
>
> --   
> Christian Hammond - chri...@beanbaginc.com <javascript:>   
> Review Board - https://www.reviewboard.org   
> Beanbag, Inc. - https://www.beanbaginc.com 
>
> -----Original Message----- 
> From: Norman Lo <norm...@gmail.com <javascript:>> 
> Reply: revie...@googlegroups.com <javascript:> <revie...@googlegroups.com 
> <javascript:>>> 
> Date: December 15, 2014 at 1:37:18 PM 
> To: revie...@googlegroups.com <javascript:> <revie...@googlegroups.com 
> <javascript:>>> 
> Subject:  Re: Unable to post files to a review 
>
> > I added the -d option, which shows the debu (shown below). It looks like 
> it 
> > is still trying to do a diff ? 
> >   
> > >>> Command exited with rc 128: ['git', 'diff', '--no-color', 
> > '--full-index', '--ignore-submodules', 
> > 
> '5d095244494ee46260897bc770bf3aa0eb3f9a12..5d095244494ee46260897bc770bf3aa0eb3f9a12',
>  
>   
> > '-M', '--no-ext-diff', '--', '/var/foobar3/testrepo3/hello.c'] 
> > []--- 
> > Traceback (most recent call last): 
> > File "/usr/bin/rbt", line 9, in   
> > load_entry_point('RBTools==0.6.3', 'console_scripts', 'rbt')() 
> > File 
> > 
> "/usr/lib/python2.6/site-packages/RBTools-0.6.3-py2.6.egg/rbtools/commands/main.py",
>  
>   
> > line 134, in main 
> > command.run_from_argv([RB_MAIN, command_name] + args) 
> > File 
> > 
> "/usr/lib/python2.6/site-packages/RBTools-0.6.3-py2.6.egg/rbtools/commands/__init__.py",
>  
>   
> > line 416, in run_from_argv 
> > exit_code = self.main(*args) or 0 
> > File 
> > 
> "/usr/lib/python2.6/site-packages/RBTools-0.6.3-py2.6.egg/rbtools/commands/post.py",
>  
>   
> > line 745, in main 
> > extra_args=extra_args) 
> > File 
> > 
> "/usr/lib/python2.6/site-packages/RBTools-0.6.3-py2.6.egg/rbtools/clients/git.py",
>  
>   
> > line 431, in diff 
> > files) 
> > File 
> > 
> "/usr/lib/python2.6/site-packages/RBTools-0.6.3-py2.6.egg/rbtools/clients/git.py",
>  
>   
> > line 490, in make_diff 
> > return ''.join(diff_lines) 
> > TypeError 
> >   
> > On Monday, December 15, 2014 3:13:02 PM UTC-5, Norman Lo wrote: 
> > > 
> > > Hello, 
> > > 
> > > I am using RBTools version 0.6.3 and tries to post some files to 
> > > ReviewBoard version 1.7. 
> > > 
> > > When I use the command "rbt post hello.c", I got the following error: 
> > > 
> > > Failed to execute command: ['git', 'rev-parse', 'hello.c^'] 
> > > fatal: ambiguous argument 'hello.c^': unknown revision or path not in 
> the 
> > > working tree. 
> > > Use '--' to separate paths from revisions 
> > > hello.c^ 
> > > 
> > > It looks like the character "^" is added somehow and it is causing git 
> to 
> > > fail. How should I go about to resolve this issue. 
> > > 
> > > 
> > > Also, I have another issue with ReviewBoard. I set it to do logging in 
> the 
> > > web interface. However, Looking at the log file, I only see: 
> > > 
> > > Reloading logging settings 
> > > 
> > > 
> > > And there are no more log entries. I do not see any apache error log. 
> How 
> > > do I resolve this issue 
> > > 
> > > Thanks! 
> > > 
> >   
> > -- 
> > Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/ 
> > --- 
> > Sign up for Review Board hosting at RBCommons: https://rbcommons.com/ 
> > --- 
> > Happy user? Let us know at http://www.reviewboard.org/users/ 
> > --- 
> > You received this message because you are subscribed to the Google 
> Groups "reviewboard"   
> > group. 
> > To unsubscribe from this group and stop receiving emails from it, send 
> an email to reviewboard...@googlegroups.com <javascript:>.   
> > For more options, visit https://groups.google.com/d/optout. 
> >   
>
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to