Hey Julian,

You're not able to post to either our server or your internal one?

Are you posting using the official upstream build of RBTools, or one from your 
source tree? I just want to rule out any issues there.

Are you behind any kind of proxy server that could potentially be interfering?

If you delete the .rbtools-cookies file and run rbt post, does it prompt you 
for credentials, or does it just try without them?

Christian

--  
Christian Hammond - christ...@beanbaginc.com  
Review Board - https://www.reviewboard.org  
Beanbag, Inc. - https://www.beanbaginc.com

-----Original Message-----
From: Julian Mehnle <jul...@mehnle.net>
Reply: reviewboard@googlegroups.com <reviewboard@googlegroups.com>>
Date: January 6, 2015 at 2:59:25 PM
To: reviewboard@googlegroups.com <reviewboard@googlegroups.com>>
Subject:  "You are not logged in (HTTP 401, API Error 103)"

> Hi all,
>  
> I'm having trouble using rbt on the command line. No matter what I do, 
> anything that requires  
> interaction with the Review Board server gives me a "You are not logged in 
> (HTTP 401, API  
> Error 103)":
>  
> > joule:~/tmp/rbtools.orig> rbt --version
> > RBTools 0.6.3
> > joule:~/tmp/rbtools.orig> git log --stat master ^origin/master | more
> > commit 86dc0ab71c20a599c33efa7ea694c12281fe8ef6
> > Author: Julian Mehnle  
> > Date: Tue Jan 6 22:45:19 2015 +0000
> >
> > When raising CommandError, include lower-level exception.
> >
> > rbtools/commands/__init__.py | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> > joule:~/tmp/rbtools.orig> rbt post --debug -g
> > >>> RBTools 0.6.3
> > >>> Python 2.7.9 (default, Dec 13 2014, 15:13:49)
> > [GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.56)]
> > >>> Running on Darwin-14.0.0-x86_64-i386-64bit
> > >>> Home = /Users/julian
> > >>> Current directory = /Users/julian/tmp/rbtools.orig
> > >>> Checking for a Subversion repository...
> > >>> Running: svn info --non-interactive
> > >>> Command exited with rc 1: ['svn', 'info', '--non-interactive']
> > svn: E155007: '/Users/julian/tmp/rbtools.orig' is not a working copy
> > ---
> > >>> Checking for a Git repository...
> > >>> Running: git rev-parse --git-dir
> > >>> Running: git config core.bare
> > >>> Running: git rev-parse --show-toplevel
> > >>> Running: git symbolic-ref -q HEAD
> > >>> Running: git config --get branch.master.merge
> > >>> Running: git config --get branch.master.remote
> > >>> Running: git config --get remote.origin.url
> > >>> repository info: Path: git://github.com/reviewboard/rbtools.git, Base 
> > >>> path:  
> , Supports changesets: False
> > >>> Making HTTP GET request to https://reviews.reviewboard.org/api/
> > >>> Running: git rev-parse refs/heads/master
> > >>> Running: git merge-base 86dc0ab71c20a599c33efa7ea694c12281fe8ef6 
> > >>> origin/master  
> > >>> Running: git rev-parse bcb7629c0be773b6f347a5006224825b8726c479
> > >>> Running: git status --porcelain --untracked-files=no
> > >>> Running: git diff --no-color --full-index --ignore-submodules 
> > >>> bcb7629c0be773b6f347a5006224825b8726c479..86dc0ab71c20a599c33efa7ea694c12281fe8ef6
> > >>>   
> -M --no-ext-diff
> > >>> Running: git log --reverse --pretty=format:%s%n%n%b 
> > >>> ^bcb7629c0be773b6f347a5006224825b8726c479  
> 86dc0ab71c20a599c33efa7ea694c12281fe8ef6
> > >>> Making HTTP GET request to 
> > >>> https://reviews.reviewboard.org/api/review-requests/  
> > >>> Making HTTP POST request to 
> > >>> https://reviews.reviewboard.org/api/review-requests/  
> > >>> Got API Error 103 (HTTP code 401): You are not logged in
> > >>> Error data: {u'stat': u'fail', u'err': {u'msg': u'You are not logged 
> > >>> in', u'code':  
> 103}}
> > Traceback (most recent call last):
> > File "/usr/local/bin/rbt", line 9, in  
> > load_entry_point('RBTools==0.6.3', 'console_scripts', 'rbt')()
> > File 
> > "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/RBTools-0.6.3-py2.7.egg/rbtools/commands/main.py",
> >   
> line 134, in main
> > command.run_from_argv([RB_MAIN, command_name] + args)
> > File 
> > "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/RBTools-0.6.3-py2.7.egg/rbtools/commands/__init__.py",
> >   
> line 416, in run_from_argv
> > exit_code = self.main(*args) or 0
> > File 
> > "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/RBTools-0.6.3-py2.7.egg/rbtools/commands/post.py",
> >   
> line 791, in main
> > submit_as=self.options.submit_as)
> > File 
> > "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/RBTools-0.6.3-py2.7.egg/rbtools/commands/post.py",
> >   
> line 507, in post_request
> > raise CommandError("Error creating review request: %s" % e)
> > rbtools.commands.CommandError: Error creating review request: You are not 
> > logged  
> in (HTTP 401, API Error 103)
>  
>  
> I've tried removing ~/.rbtools-cookies, as well as specifying --username and 
> --password  
> on the command line, to no avail. I've tried both posting to 
> https://reviews.reviewboard.org  
> and my company's internal Review Board server (running RB 1.7.19. I'm running 
> Python  
> 2.7.9 on Mac OS X 10.10.1.
>  
> I'm not sure what triggered this. How should I go about debugging this?
>  
> -Julian
>  
> --
> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
> ---
> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> ---
> Happy user? Let us know at http://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups 
> "reviewboard"  
> group.
> To unsubscribe from this group and stop receiving emails from it, send an 
> email to reviewboard+unsubscr...@googlegroups.com.  
> For more options, visit https://groups.google.com/d/optout.
>  

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to