Dear All,

I just found out that perforce repository is registered as hostname:1666,
when RBTools send this name it automatically converts it to IP address,
while doing verification it found that repository is not present and it
report below error message.

The repository path "['', 'pf-xxx:1666']" is not in the
list of known repositories on the server.

Ask the administrator to add this repository to the Review Board server.
For information on adding repositories, please read

Even though we pass perforce repository name ass hostname it take name ass
IP address and while validating it find that The repository path specified
is not in the list of known repositories.

I shouldn't be asking this but still can we attach same perforce repository
one as hostname and same perforce as IP address.?

Thank for help.


On Tue, Jan 13, 2015 at 11:50 PM, Nilesh Jaiswal <>

> I see document note say.
> HTTP 404: Not Found
> Error 203: Invalid Change Number
> The change number specified does not match any known change number in the
> repository.
>  What could be the reason, I guess the change number specified with review
> request are valid.
> please advise.
> On Tue, Jan 13, 2015 at 11:35 PM, Nilesh Jaiswal <>
> wrote:
>> Hi All,
>> All of a sudden my RBTools starts reporting for all the users who tries
>> to post review request. Let me know if this is right group for this query.
>> We use RB server version 1.7.5 and its RBTools version.
>> urllib2.HTTPError: HTTP Error 404: Not Found
>> There was no changes, what could be the reason.
>> Can you please help us know.
>> Thanks,
>> Nilesh

Get the Review Board Power Pack at
Sign up for Review Board hosting at RBCommons:
Happy user? Let us know at
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to