Authentication is done via AD.

- David

On Tuesday, January 13, 2015 at 9:30:54 PM UTC+2, David Resnick wrote:
>
> I only have the problem with RBTools, not with the web UI or even 
> post-review.
>
> It seems that others also have the same problem, also just when using rbt.
>
> I'm looking into the mechanism used for authentication, it is either LDAP 
> or AD.
>
> - David
>
> On Monday, January 12, 2015 at 11:37:31 PM UTC+2, Christian Hammond wrote:
>>
>> Do you have to log into the web UI frequently as well, or is it just with 
>> RBTools? 
>>
>> Would you be able to find out what authentication mechanism is being used 
>> on Review Board? LDAP, Active Directory, etc.? 
>>
>> Any idea if anybody else is having this problem there? 
>>
>> It sort of sounds like the session is expiring too soon on the server, or 
>> isn't retrievable after use, as if it's not actually being stored. 
>>
>> Christian 
>>
>> --   
>> Christian Hammond - chri...@beanbaginc.com   
>> Review Board - https://www.reviewboard.org   
>> Beanbag, Inc. - https://www.beanbaginc.com 
>>
>> -----Original Message----- 
>> From: David Resnick <abun...@gmail.com> 
>> Reply: revie...@googlegroups.com <revie...@googlegroups.com>> 
>> Date: January 11, 2015 at 11:43:31 PM 
>> To: revie...@googlegroups.com <revie...@googlegroups.com>> 
>> Subject:  Re: Always being prompted for password with "rbt post" 
>>
>> > Writable and seemingly updated each time I use rbt. 
>> >   
>> > $ cat ~/.rbtools-cookies 
>> > # Netscape HTTP Cookie File 
>> > # http://curl.haxx.se/rfc/cookie_spec.html 
>> > # This is a generated file! Do not edit. 
>> >   
>> > reviewboard.company.com FALSE / FALSE 1451493075 
>> > rbsessionid d6cmm1l5fcbaw50ofigpns45kio4gukh 
>> >   
>> > On Wednesday, January 7, 2015 at 11:20:59 PM UTC+2, David Trowbridge 
>> wrote: 
>> > > 
>> > > Can you check to make sure that ~/.rbtools-cookies is writable by 
>> your 
>> > > user? 
>> > > 
>> > > -David 
>> > > On Wed Jan 07 2015 at 9:28:55 AM David Resnick > > > wrote: 
>> > > 
>> > >> I've been having this problem for a while. I encountered this both 
>> on Mac 
>> > >> (10.10) and Ubunu 14.04. 
>> > >> 
>> > >> RBTools 0.6.3, Reviewboard 2.0.10 
>> > >> 
>> > >> $ rbt post --debug 
>> > >> >>> RBTools 0.6.3 
>> > >> >>> Python 2.7.9 (default, Dec 19 2014, 06:00:59) 
>> > >> [GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.56)] 
>> > >> >>> Running on Darwin-14.0.0-x86_64-i386-64bit 
>> > >> >>> Home = /Users/username 
>> > >> >>> Current directory = /Users/username/proj/project/support 
>> > >> >>> Checking for a Subversion repository... 
>> > >> >>> Running: svn info --non-interactive 
>> > >> >>> Command exited with rc 1: ['svn', 'info', '--non-interactive'] 
>> > >> svn: E155007: '/Users/username/proj/project/support' is not a 
>> working copy 
>> > >> --- 
>> > >> >>> Checking for a Git repository... 
>> > >> >>> Running: git rev-parse --git-dir 
>> > >> >>> Running: git config core.bare 
>> > >> >>> Running: git rev-parse --show-toplevel 
>> > >> >>> Running: git symbolic-ref -q HEAD 
>> > >> >>> Running: git config --get branch.phdl-build.merge 
>> > >> >>> Command exited with rc 1: ['git', 'config', '--get', 
>> > >> 'branch.phdl-build.merge'] 
>> > >> --- 
>> > >> >>> Running: git config --get branch.phdl-build.remote 
>> > >> >>> Command exited with rc 1: ['git', 'config', '--get', 
>> > >> 'branch.phdl-build.remote'] 
>> > >> --- 
>> > >> >>> Running: git config --get remote.origin.url 
>> > >> >>> repository info: Path: ssh://g...@git.company.com/project.git, 
>> Base 
>> > >> path: , Supports changesets: False 
>> > >> >>> Making HTTP GET request to https://reviewboard.company.com/api/ 
>> > >> 
>> > >> ==> HTTP Authentication Required 
>> > >> Enter authorization information for "Web API" at 
>> reviewboard.company.com 
>> > >> Password: 
>> > >> 
>> > >> Anything I can change locally to fix this? 
>> > >> 
>> > >> Thanks, 
>> > >> David 
>> > >> 
>> > >> -- 
>> > >> Get the Review Board Power Pack at 
>> http://www.reviewboard.org/powerpack/ 
>> > >> --- 
>> > >> Sign up for Review Board hosting at RBCommons: 
>> https://rbcommons.com/ 
>> > >> --- 
>> > >> Happy user? Let us know at http://www.reviewboard.org/users/ 
>> > >> --- 
>> > >> You received this message because you are subscribed to the Google 
>> Groups 
>> > >> "reviewboard" group. 
>> > >> To unsubscribe from this group and stop receiving emails from it, 
>> send an 
>> > >> email to reviewboard...@googlegroups.com . 
>> > >> For more options, visit https://groups.google.com/d/optout. 
>> > >> 
>> > > 
>> >   
>> > -- 
>> > Get the Review Board Power Pack at 
>> http://www.reviewboard.org/powerpack/ 
>> > --- 
>> > Sign up for Review Board hosting at RBCommons: https://rbcommons.com/ 
>> > --- 
>> > Happy user? Let us know at http://www.reviewboard.org/users/ 
>> > --- 
>> > You received this message because you are subscribed to the Google 
>> Groups "reviewboard"   
>> > group. 
>> > To unsubscribe from this group and stop receiving emails from it, send 
>> an email to reviewboard...@googlegroups.com.   
>> > For more options, visit https://groups.google.com/d/optout. 
>> >   
>>
>>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to