I'm pasting the debug output here:

$ rbt post -r 27 --svn-show-copies-as-adds=y -d                            
>>> RBTools 0.7.1 
>>> Python 2.7.9 (default, Dec 11 2014, 04:42:00)  
[GCC 4.9.2] 
>>> Running on Linux-3.18.6-1-ARCH-x86_64-with-glibc2.2.5 
>>> Home = /home/bogdano 
>>> Current directory = /home/bogdano/WORK/path/to/project 
>>> Checking for a Subversion repository... 
>>> Running: svn info --non-interactive 
>>> Running: diff --version 
>>> repository info: Path: http://server/svn, Base path: 
/TRUNK/path/to/project, Supports changesets: False 
>>> Making HTTP GET request to http://reviewboard/reviews/api/ 
>>> Making HTTP GET request to http://reviewboard/reviews/api/repositories/ 
>>> Running: svn info --non-interactive 
>>> Running: diff --version 
>>> repository info: Path: http://server/svn, Base path: 
/TRUNK/path/to/project, Supports changesets: False 
>>> Running: svn status --ignore-externals 
>>> Running: svn diff --diff-cmd=diff --notice-ancestry -r BASE --show-
copies-as-adds 
Traceback (most recent call last): 
  File "/usr/bin/rbt", line 9, in <module> 
    load_entry_point('RBTools==0.7.1', 'console_scripts', 'rbt')() 
  File "/usr/lib/python2.7/site-packages/rbtools/commands/main.py", line 133
, in main 
    command.run_from_argv([RB_MAIN, command_name] + args) 
  File "/usr/lib/python2.7/site-packages/rbtools/commands/__init__.py", 
line 538, in run_from_argv 
    exit_code = self.main(*args) or 0 
  File "/usr/lib/python2.7/site-packages/rbtools/commands/post.py", line 639
, in main 
    extra_args=extra_args) 
  File "/usr/lib/python2.7/site-packages/rbtools/clients/svn.py", line 297, 
in diff 
    diff = self._run_svn(diff_cmd, split_lines=True) 
  File "/usr/lib/python2.7/site-packages/rbtools/clients/svn.py", line 658, 
in _run_svn 
    return execute(cmdline, *args, **kwargs) 
  File "/usr/lib/python2.7/site-packages/rbtools/utils/process.py", line 104
, in execute 
    data = [line.decode('utf-8') for line in data] 
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode 
    return codecs.utf_8_decode(input, errors, True) 
UnicodeDecodeError: 'utf8' codec cant decode byte 0x96 in position 19: 
invalid start byte

I ran 
svn diff --diff-cmd=diff --notice-ancestry -r BASE --show-copies-as-adds

and it executed with no errors. I cannot show the diff, but I can look for 
something in it.


miercuri, 11 martie 2015, 09:27:09 UTC+2, Ovidiu-Florin BOGDAN a scris:
>
> I've made some changes and added a few new files in my SVN checkout. Now 
> I'm trying to update a review request using rbtools.
>
>  $ rbt post -r 27 
> One or more files in your changeset has history scheduled with commit. 
> Please try again with '--svn-show-copies-a
> s-adds=y/n'
>
>  $ rbt post -r 27 --svn-show-copies-as-adds=y 
> CRITICAL: 'utf8' codec cant decode byte 0x96 in position 19: invalid 
> start byte
>
> I have no idea what this refers to.
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to