Christian,

I updated the installation, and now everything is looking fine. Thanks for 
the quick response!

Regards,
    Johan Borkhuis


On Thursday, March 19, 2015 at 1:53:47 AM UTC+1, Christian Hammond wrote:
>
> Hi Johan,
>
> Go ahead and upgrade both Djblets and Power Pack:
>
>     sudo easy_install -U Djblets ReviewBoardPowerPack
>
> And restart Apache. Things should be working now. Let me know if that's 
> not the case :)
>
> Thanks for your patience!
>
> Christian
>
> -- 
> Christian Hammond - chri...@beanbaginc.com <javascript:>
> Review Board - http://www.reviewboard.org
> Beanbag, Inc. - http://www.beanbaginc.com
>
> On Wed, Mar 18, 2015 at 3:26 PM, Christian Hammond <chri...@beanbaginc.com 
> <javascript:>> wrote:
>
>> Hi,
>>
>> I found the problem. I'll be working on getting new Djblets and Power 
>> Pack releases out today that fix it.
>>
>> Christian
>>
>> -- 
>> Christian Hammond - chri...@beanbaginc.com <javascript:>
>> Review Board - http://www.reviewboard.org
>> Beanbag, Inc. - http://www.beanbaginc.com
>>
>> On Wed, Mar 18, 2015 at 2:47 PM, Christian Hammond <
>> chri...@beanbaginc.com <javascript:>> wrote:
>>
>>> Hi Johan,
>>>
>>> Glad I wasn't totally imagining things, but I realize now that that was 
>>> our build machine's file path we're seeing.
>>>
>>> It does look like commenting here has regressed. I'm looking into it, 
>>> and will let you know what I find out.
>>>
>>> Christian
>>>
>>> -- 
>>> Christian Hammond - chri...@beanbaginc.com <javascript:>
>>> Review Board - http://www.reviewboard.org
>>> Beanbag, Inc. - http://www.beanbaginc.com
>>>
>>> On Wed, Mar 18, 2015 at 8:03 AM, Johan Borkhuis <bork...@gmail.com 
>>> <javascript:>> wrote:
>>>
>>>> Christian,
>>>>
>>>> I did install python-imaging, and updated ReviewBoard and PowerPack 
>>>> (and also did an rb-site upgrade and restart of Apache) and now I get the 
>>>> image on the review-page. Also the "Loading..." at the top is gone and no 
>>>> errors are reported anymore.
>>>>
>>>> But creating a review-comments is still not possible. I still get an 
>>>> "Error saving comment: HTTP 500 INTERNAL SERVER ERROR". But there are no 
>>>> messages in the reviewboard log, and also no errors in the Apache log 
>>>> (except for the HTTP 500 message).
>>>>
>>>> BTW: I now saw where your reference to OSX came from, in the logfile.
>>>>
>>>> Regards,
>>>>     Johan
>>>>
>>>>
>>>> On Wednesday, March 18, 2015 at 12:24:41 PM UTC+1, Johan Borkhuis wrote:
>>>>>
>>>>> Christian,
>>>>>
>>>>> 3 AM is not the best time for things like this (I know from my own 
>>>>> experience :-), but I really appreciate the help. I will start looking 
>>>>> into 
>>>>> the direction you indicated, and if I have any additional info I will 
>>>>> share 
>>>>> that.
>>>>>
>>>>> Regards,
>>>>>     Johan Borkhuis
>>>>>
>>>>>
>>>>> On Wednesday, March 18, 2015 at 11:16:44 AM UTC+1, Christian Hammond 
>>>>> wrote:
>>>>>>
>>>>>> Hi Johan, 
>>>>>>
>>>>>> My apologies. I thought I read an OSX-related path in that output 
>>>>>> (which had confused me), but I must have been looking at something else. 
>>>>>> (It's 3AM here now -- I'm pretty tired.) 
>>>>>>
>>>>>> Okay, given that it's Debian, what I'd suggest is seeing if there's a 
>>>>>> newer PIL or Pillow package that you can apt-get. This likely will have 
>>>>>> the 
>>>>>> right modules compiled. 
>>>>>>
>>>>>> Failing that, what you'd want to do is remove PIL from the system, 
>>>>>> then ensure you have the development packages needed to build Pillow. 
>>>>>> These 
>>>>>> instructions should serve as a starting point: 
>>>>>>
>>>>>> http://pillow.readthedocs.org/en/latest/installation.html#
>>>>>> linux-installation 
>>>>>>
>>>>>> You can then install Pillow using easy_install or pip install. As 
>>>>>> part of the install process, it will compile Pillow against those 
>>>>>> modules, 
>>>>>> and give you a summary of what decoders are included and what are 
>>>>>> missing. 
>>>>>>
>>>>>> Once you have an upgraded version, restart Apache and give it another 
>>>>>> try. It should begin to work. 
>>>>>>
>>>>>> If you still have problems, I'll be happy to help out with them after 
>>>>>> I get some sleep :) 
>>>>>>
>>>>>> Christian 
>>>>>>
>>>>>> --   
>>>>>> Christian Hammond - chri...@beanbaginc.com   
>>>>>> Review Board - https://www.reviewboard.org   
>>>>>> Beanbag, Inc. - https://www.beanbaginc.com 
>>>>>>
>>>>>> -----Original Message----- 
>>>>>> From: Johan Borkhuis <bork...@gmail.com> 
>>>>>> Reply: Johan Borkhuis <bork...@gmail.com>> 
>>>>>> Date: March 18, 2015 at 2:29:39 AM 
>>>>>> To: revie...@googlegroups.com <revie...@googlegroups.com>> 
>>>>>> Cc: bork...@gmail.com <bork...@gmail.com>>, chri...@beanbaginc.com <
>>>>>> chri...@beanbaginc.com>> 
>>>>>> Subject:  Re: Issues with document review in Powerpack 
>>>>>>
>>>>>> > Christian, 
>>>>>> >   
>>>>>> > I have PIL-1.1.7-py2.7-linux-i686.egg installed. We are not using 
>>>>>> OS X, we 
>>>>>> > are running on a Debian 7.4 host. 
>>>>>> >   
>>>>>> > The following packages are installed (I skipped Django, Djblets and 
>>>>>> > ReviewBoard packages): 
>>>>>> > docutils-0.11-py2.7.egg 
>>>>>> > easy-install.pth 
>>>>>> > ecdsa-0.10-py2.7.egg 
>>>>>> > feedparser-5.1.3-py2.7.egg 
>>>>>> > futures-2.1.6-py2.7.egg 
>>>>>> > Markdown-2.4.1-py2.7.egg 
>>>>>> > Markdown-2.4-py2.7.egg 
>>>>>> > mimeparse-0.1.3-py2.7.egg 
>>>>>> > paramiko-1.12.2-py2.7.egg 
>>>>>> > PIL-1.1.7-py2.7-linux-i686.egg 
>>>>>> > pillowfight-0.2-py2.7.egg 
>>>>>> > pycrypto-2.6.1-py2.7-linux-i686.egg 
>>>>>> > Pygments-1.6-py2.7.egg 
>>>>>> > python_dateutil-1.5-py2.7.egg 
>>>>>> > python_memcached-1.53-py2.7.egg 
>>>>>> > python_ntlm-1.1.0-py2.7.egg 
>>>>>> > pytz-2013.9-py2.7.egg 
>>>>>> > rbnotefield-1.0-py2.7.egg 
>>>>>> > rbseverity-0.5.1-py2.7.egg 
>>>>>> > recaptcha_client-1.0.6-py2.7.egg 
>>>>>> > Whoosh-2.6.0-py2.7.egg 
>>>>>> >   
>>>>>> > Regards, 
>>>>>> > Johan 
>>>>>> >   
>>>>>> > On Wednesday, March 18, 2015 at 10:21:19 AM UTC+1, Christian 
>>>>>> Hammond wrote: 
>>>>>> > > 
>>>>>> > > Hi Johan, 
>>>>>> > > 
>>>>>> > > Okay, this sounds like your version of PIL or Pillow is missing a 
>>>>>> decoder 
>>>>>> > > needed for thumbnail generation to work. 
>>>>>> > > 
>>>>>> > > First, can you verify which you're using? You can look to see if 
>>>>>> a PIL or 
>>>>>> > > Pillow directory is in /usr/local/lib/python2.7/dist-packages/. 
>>>>>> > > 
>>>>>> > > Also, do you use homebrew? On MacOS X, there's a couple different 
>>>>>> ways to 
>>>>>> > > fix this, so I want to make sure I give you decent instructions. 
>>>>>> > > 
>>>>>> > > Pillow is the modern replacement for PIL, and is easier to 
>>>>>> install and get 
>>>>>> > > running. If you're using PIL, we'll probably have you uninstall 
>>>>>> it and 
>>>>>> > > install Pillow in its place. However, we'll need to make sure you 
>>>>>> have a 
>>>>>> > > couple of libraries installed first, to ensure it has this 
>>>>>> decoder. 
>>>>>> > > 
>>>>>> > > Christian 
>>>>>> > > 
>>>>>> > > -- 
>>>>>> > > Christian Hammond - chri...@beanbaginc.com   
>>>>>> > > Review Board - https://www.reviewboard.org 
>>>>>> > > Beanbag, Inc. - https://www.beanbaginc.com 
>>>>>> > > 
>>>>>> > > -----Original Message----- 
>>>>>> > > From: Johan Borkhuis > 
>>>>>> > > Reply: Johan Borkhuis >> 
>>>>>> > > Date: March 18, 2015 at 2:11:41 AM 
>>>>>> > > To: revie...@googlegroups.com > > >> 
>>>>>> > > Cc: bork...@gmail.com >>, 
>>>>>> > > chri...@beanbaginc.com >>   
>>>>>> > > 
>>>>>> > > Subject: Re: Issues with document review in Powerpack 
>>>>>> > > 
>>>>>> > > > Christian, 
>>>>>> > > > 
>>>>>> > > > I enabled logging in ReviewBoard: 
>>>>>> > > > 
>>>>>> > > > 2015-03-18 08:56:18,605 - ERROR - - Failed to convert data uri 
>>>>>> to image: 
>>>>>> > > > decoder zip not available. 
>>>>>> > > > 2015-03-18 08:56:18,606 - ERROR - - Error when calling 
>>>>>> get_thumbnail for 
>>>>>> > > > MimetypeHandler > 0xba792b0c>: decoder zip not available 
>>>>>> > > > Traceback (most recent call last): 
>>>>>> > > > File 
>>>>>> > > > 
>>>>>> > > "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.
>>>>>> 15-py2.7.egg/reviewboard/attachments/models.py",   
>>>>>> > > 
>>>>>> > > > line 89, in _set_thumbnail 
>>>>>> > > > self.mimetype_handler.set_thumbnail(data) 
>>>>>> > > > File 
>>>>>> > > > "build/bdist.macosx-10.10-intel/egg/rbpowerpack/pdf/mimetypes.py", 
>>>>>>   
>>>>>> > > > line 85, in set_thumbnail 
>>>>>> > > > IOError: decoder zip not available 
>>>>>> > > > 
>>>>>> > > > No JavaScript errors are reported, only the file is being 
>>>>>> downloaded 
>>>>>> > > > multiple times per second, so the log is being flushed with 
>>>>>> these 
>>>>>> > > messages. 
>>>>>> > > > 
>>>>>> > > > When trying to create a comment in the document I get this 
>>>>>> error: 
>>>>>> > > > TypeError: this.commentDlg.is is not a function 
>>>>>> > > > 
>>>>>> > > http://revboard.eu.omron.net/static/ext/rbpowerpack.
>>>>>> extension.PowerPackExtension/js/powerpack-pdf.min.aaa0c6673283.js   
>>>>>> > > 
>>>>>> > > > Line 1 
>>>>>> > > > 
>>>>>> > > > This also gives the following message in the ReviewBoard log: 
>>>>>> > > > 2015-03-18 09:09:44,054 - ERROR - - PDF Review UI: Could not 
>>>>>> convert 
>>>>>> > > > thumbnailData to stored image for file attachment comment 109: 
>>>>>> decoder 
>>>>>> > > zip 
>>>>>> > > > not available 
>>>>>> > > > 
>>>>>> > > > It looks like both are related to a missing decoder zip. 
>>>>>> > > > 
>>>>>> > > > BTW: I also use Comment Severity 0.5.1 
>>>>>> > > > 
>>>>>> > > > Regards, 
>>>>>> > > > Johan 
>>>>>> > > > 
>>>>>> > > > On Wednesday, March 18, 2015 at 9:25:31 AM UTC+1, Christian 
>>>>>> Hammond 
>>>>>> > > wrote: 
>>>>>> > > > > 
>>>>>> > > > > Hi Johan, 
>>>>>> > > > > 
>>>>>> > > > > Is there anything in the reviewboard.log file (if that's 
>>>>>> enabled)? 
>>>>>> > > > > 
>>>>>> > > > > The "request_info" KeyError usually indicates that something 
>>>>>> with the 
>>>>>> > > > > Review Board logging setup got into an inconsistent state. It 
>>>>>> might be 
>>>>>> > > > > masking the real error. 
>>>>>> > > > > 
>>>>>> > > > > Also, when you load a page with a PDF file, and it just spins 
>>>>>> > > > > indefinitely, are there any JavaScript errors in the 
>>>>>> browser's 
>>>>>> > > JavaScript 
>>>>>> > > > > console? 
>>>>>> > > > > 
>>>>>> > > > > Thanks, 
>>>>>> > > > > 
>>>>>> > > > > Christian 
>>>>>> > > > > 
>>>>>> > > > > -- 
>>>>>> > > > > Christian Hammond - chri...@beanbaginc.com 
>>>>>> > > > > Review Board - https://www.reviewboard.org 
>>>>>> > > > > Beanbag, Inc. - https://www.beanbaginc.com 
>>>>>> > > > > 
>>>>>> > > > > -----Original Message----- 
>>>>>> > > > > From: Johan Borkhuis > 
>>>>>> > > > > Reply: revie...@googlegroups.com > > >> 
>>>>>> > > > > Date: March 18, 2015 at 1:20:55 AM 
>>>>>> > > > > To: revie...@googlegroups.com > > >> 
>>>>>> > > > > Subject: Issues with document review in Powerpack 
>>>>>> > > > > 
>>>>>> > > > > > We are trying Powerpack, and we came across some issues 
>>>>>> with the 
>>>>>> > > > > document 
>>>>>> > > > > > review: 
>>>>>> > > > > > 
>>>>>> > > > > > - After creating a document review the page shows a 
>>>>>> "Loading..." box 
>>>>>> > > at 
>>>>>> > > > > > the top that continuously appears and disappears and there 
>>>>>> is no 
>>>>>> > > image 
>>>>>> > > > > in 
>>>>>> > > > > > the document box, only the rotating dots. Other people get 
>>>>>> a yellow 
>>>>>> > > > > warning 
>>>>>> > > > > > sign. 
>>>>>> > > > > > - When trying to enter a comment in the document I get a 
>>>>>> popup with 
>>>>>> > > > > > "Error saving comment: HTTP 500 INTERNAL SERVER ERROR". 
>>>>>> > > > > > 
>>>>>> > > > > > I tried removing the attached PDF and uploading it again, 
>>>>>> but this 
>>>>>> > > did 
>>>>>> > > > > not 
>>>>>> > > > > > help. 
>>>>>> > > > > > 
>>>>>> > > > > > We are using RB 2.0.15 with PowerPack 1.2.1. Are there any 
>>>>>> other 
>>>>>> > > > > required 
>>>>>> > > > > > packages that I need for this to work? 
>>>>>> > > > > > 
>>>>>> > > > > > From the apache error.log: 
>>>>>> > > > > > 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] Traceback (most recent 
>>>>>> call 
>>>>>> > > last): 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] File 
>>>>>> > > > > > "/usr/lib/python2.7/logging/__init__.py", line 850, in 
>>>>>> emit 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] msg = 
>>>>>> self.format(record) 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] File 
>>>>>> > > > > > "/usr/lib/python2.7/logging/__init__.py", line 723, in 
>>>>>> format 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] return 
>>>>>> fmt.format(record) 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] File 
>>>>>> > > > > > "/usr/lib/python2.7/logging/__init__.py", line 467, in 
>>>>>> format 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] s = self._fmt % 
>>>>>> record.__dict__ 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] KeyError: 
>>>>>> u'request_info' 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] Logged from file 
>>>>>> mimetypes.py, 
>>>>>> > > line 
>>>>>> > > > > 84 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] Traceback (most recent 
>>>>>> call 
>>>>>> > > last): 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] File 
>>>>>> > > > > > "/usr/lib/python2.7/logging/__init__.py", line 850, in 
>>>>>> emit 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] msg = 
>>>>>> self.format(record) 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] File 
>>>>>> > > > > > "/usr/lib/python2.7/logging/__init__.py", line 723, in 
>>>>>> format 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] return 
>>>>>> fmt.format(record) 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] File 
>>>>>> > > > > > "/usr/lib/python2.7/logging/__init__.py", line 467, in 
>>>>>> format 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] s = self._fmt % 
>>>>>> record.__dict__ 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] KeyError: 
>>>>>> u'request_info' 
>>>>>> > > > > > [Wed Mar 18 08:06:38 2015] [error] Logged from file 
>>>>>> models.py, line 
>>>>>> > > 93 
>>>>>> > > > > > 
>>>>>> > > > > > Regards, 
>>>>>> > > > > > 
>>>>>> > > > > > Johan Borkhuis 
>>>>>> > > > > > 
>>>>>> > > > > > -- 
>>>>>> > > > > > Supercharge your Review Board with Power Pack: 
>>>>>> > > > > https://www.reviewboard.org/powerpack/ 
>>>>>> > > > > > Want us to host Review Board for you? Check out RBCommons: 
>>>>>> > > > > https://rbcommons.com/ 
>>>>>> > > > > > Happy user? Let us know! https://www.reviewboard.org/users/ 
>>>>>> > > > > > --- 
>>>>>> > > > > > You received this message because you are subscribed to the 
>>>>>> Google 
>>>>>> > > > > Groups "reviewboard" 
>>>>>> > > > > > group. 
>>>>>> > > > > > To unsubscribe from this group and stop receiving emails 
>>>>>> from it, 
>>>>>> > > send 
>>>>>> > > > > an email to reviewboard...@googlegroups.com . 
>>>>>> > > > > > For more options, visit https://groups.google.com/d/optout. 
>>>>>>
>>>>>> > > > > > 
>>>>>> > > > > 
>>>>>> > > > > 
>>>>>> > > 
>>>>>> > > 
>>>>>>
>>>>>>  -- 
>>>> Supercharge your Review Board with Power Pack: 
>>>> https://www.reviewboard.org/powerpack/
>>>> Want us to host Review Board for you? Check out RBCommons: 
>>>> https://rbcommons.com/
>>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>>> --- 
>>>> You received this message because you are subscribed to the Google 
>>>> Groups "reviewboard" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send 
>>>> an email to reviewboard...@googlegroups.com <javascript:>.
>>>> For more options, visit https://groups.google.com/d/optout.
>>>>
>>>
>>>
>>
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to