It could be your proxy. You may need to edit the
/path/to/site/htdocs/reviewboard.wsgi file and set environment variables
for your proxy. These should be HTTP_PROXY and HTTPS_PROXY. Then restart
Apache.

Christian

On Wednesday, September 16, 2015, Ajoy Bhatia <ajoy.bha...@gmail.com> wrote:

> I am getting this error, too, with a private organization GitHub
> repository. I enabled logging successfully (i.e. log directory is writable
> by web server), restarted the web server and tried to add the repo again.
> Got the same error but do not see anything in the log file.
>
> BTW, my ReviewBoard web server is behind another proxy server.
>
> Was there any resolution on this?
>
> Thanks...
> - Ajoy
>
> On Tuesday, September 8, 2015 at 2:33:39 PM UTC-7, Tony Dubu Yang wrote:
>>
>> Getting the same error as anoop is getting above: Unknown error when
>> linking the account: 'URLError' object has no attribute 'read'
>>
>> This happens when I attempt to add a public GitHub repository
>> (non-enterprise) to my reviewboard and click save.
>>
>> I'm trying to determine whether this is an error with sending or
>> receiving and if I (likely) need to adjust the Azure VMs settings to
>> allow... something in or out. So I'm expecting to see something along the
>> lines of "error attempting to send data" with a stack trace or "timed out
>> waiting for response" or something along those lines in the logs.
>>
>> On Tue, Sep 8, 2015 at 1:07 PM, Christian Hammond <chi...@chipx86.com>
>> wrote:
>>
>>> The CSRF verification failure is likely due to trying to re-post a form
>>> after reloading the web server. It's a protection mechanism that requires
>>> that you first load/navigate to the page, then post, all with the web
>>> server running, without restarting. It's used to prevent sites from
>>> tricking you into submitting a form on Review Board from their site without
>>> you knowing.
>>>
>>> Tony, can you show me exactly what error you're hitting and the steps
>>> you're going through?
>>>
>>> It does look like logging is enabled. What information in the logs are
>>> you expecting to find?
>>>
>>> Christian
>>>
>>> --
>>> Christian Hammond - chi...@chipx86.com
>>> Review Board - https://www.reviewboard.org
>>> Beanbag, Inc. - https://www.beanbaginc.com
>>>
>>> On Mon, Sep 7, 2015 at 11:36 PM, Tony Dubu Yang <xae...@gmail.com>
>>> wrote:
>>>
>>>> I'm receiving this error, too, running on an Azure VM with version
>>>> 2.0.19 of ReviewBoard installed. I've set the logging level for ReviewBoard
>>>> to DEBUG, but all I'm getting is cache misses and 'Using
>>>> reviewboard.scmtools.svn.pysvn backend for SVN' in the logs. Tried
>>>> looking in the /opt/bitnami/apache2/... logs, as well, but nothing of
>>>> interest shows up after running into the error.
>>>>
>>>> Any advice on where to dig to track down the error/stack trace?
>>>>
>>>> Just a note, looks like the Azure VMs don't allow ICMP as running a
>>>> ping against github.com doesn't return a result.
>>>>
>>>> On Friday, December 19, 2014 at 1:38:23 AM UTC-8, anoop kc wrote:
>>>>>
>>>>> Hi,
>>>>>
>>>>> Whenever I try to add my git repository to  reviewboard, it fails with
>>>>> the following error.
>>>>>
>>>>> Unknown error when linking the account: 'URLError' object has no
>>>>> attribute 'read'
>>>>>
>>>>> where am I doing wrong?
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>> Supercharge your Review Board with Power Pack:
>>>> https://www.reviewboard.org/powerpack/
>>>> Want us to host Review Board for you? Check out RBCommons:
>>>> https://rbcommons.com/
>>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>>>
>>>> ---
>>>> You received this message because you are subscribed to the Google
>>>> Groups "reviewboard" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send
>>>> an email to reviewboard...@googlegroups.com.
>>>> For more options, visit https://groups.google.com/d/optout.
>>>>
>>>
>>> --
>>> Supercharge your Review Board with Power Pack:
>>> https://www.reviewboard.org/powerpack/
>>> Want us to host Review Board for you? Check out RBCommons:
>>> https://rbcommons.com/
>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "reviewboard" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to reviewboard...@googlegroups.com.
>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>
>> --
> Supercharge your Review Board with Power Pack:
> https://www.reviewboard.org/powerpack/
> Want us to host Review Board for you? Check out RBCommons:
> https://rbcommons.com/
> Happy user? Let us know! https://www.reviewboard.org/users/
> ---
> You received this message because you are subscribed to the Google Groups
> "reviewboard" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to reviewboard+unsubscr...@googlegroups.com
> <javascript:_e(%7B%7D,'cvml','reviewboard%2bunsubscr...@googlegroups.com');>
> .
> For more options, visit https://groups.google.com/d/optout.
>


-- 
-- 
Christian Hammond - christ...@beanbaginc.com
Review Board - https://www.reviewboard.org
Beanbag, Inc. - https://www.beanbaginc.com

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to