Hi - I'm bringing up a new instance of RB using Perforce and I'm just 
getting things to work. I'm trying to post a review. On a ubuntu box I have 
installed rbt 7.5. When I run "rbt setup-repo --debug" I get:
>>> Checking for a Perforce repository...
>>> Running: p4 info
>>> Running: diff --version
>>> repository info: Path: server:port, Base path: None, Supports 
changesets: True
>>> Making HTTP GET request to http://server/api/
>>> Making HTTP GET request to http://server/api/repositories/
>>> Cached response for HTTP GET http://server/api/repositories/ expired 
and was modified
No Perforce repository found or selected
reviewboardrc not created.

I also tried creating my .reviewboardrc file by hand and then when I try to 
post I get

coneill-lx [560]:rbt post 329470
Generating diff for pending changeset 329470

Please log in to the Review Board server at screvboard01.mygazoo.com.
Username: coneill
ERROR: Error validating diff

The specified diff file could not be parsed. (HTTP 400, API Error 224)

coneill-lx [561]:rbt post 329470 --debug
Path '329470' does not match a valid Perforce path.

Any idea where I'm going wrong? Thanks.

Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to