I know this is old issue, but I came across similar issue.

After debugging I found, that in `/reviewboard/accounts/backends.py:837` 
was a problem with decoding UTF-8 characters coming from ActiveDirectory 
during save to mariadb/mysql. First/last name was containing polish 
characters like "ś".
Redropped database with proper UTF-8 coding resolved the issue.

Hope that it'll help someone

W dniu piątek, 20 stycznia 2012 12:57:18 UTC+1 użytkownik slaventii napisał:
> Hello, 
> I tried to setup ReviewBoard with Active Directory but I cant login 
> with my domain account. 
> In log I found: 
> 2012-01-20 03:43:19,841 - DEBUG - Search root dc=domain,dc=local 
> Authentication Method:Active Directory 
> Domain name:domain.local 
> Use TLS for authentication: with and without same result 
> Domain controller:dc.domain.local 
> I added ldap.set_option(ldap.OPT_X_TLS_REQUIRE_CERT, 
> ldap.OPT_X_TLS_ALLOW in /usr/lib/python2.4/site-packages/ 
> ReviewBoard-1.6.3-py2.4.egg/reviewboard/accounts/backends.py to work 
> with TSL 
> What I missing ? 
> Thanks.

Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to