I've tried the suggestions here:
http://stackoverflow.com/questions/11345357/review-board-diff-not-uploading

without success, and tried uploading a diff manually without luck.  Please 
advise. 

rbt post --debug
>>> RBTools 0.7.6
>>> Python 2.7.11+ (default, Apr 17 2016, 14:00:29) 
[GCC 5.3.1 20160413]
>>> Running on Linux-4.6.0-040600rc6-generic-x86_64-with-Ubuntu-16.04-xenial
>>> Home = /home/mt
>>> Current directory = /home/mt/ownCloud/src/git/ANL/RISC/SimDependency
>>> Checking for a Subversion repository...
>>> Unable to execute "svn help": skipping SVN
>>> Checking for a Git repository...
>>> Running: git rev-parse --git-dir
>>> Running: git config core.bare
>>> Running: git rev-parse --show-toplevel
>>> Running: git symbolic-ref -q HEAD
>>> Running: git config --get branch.master.merge
>>> Running: git config --get branch.master.remote
>>> Running: git config --get remote.origin.url
>>> repository info: Path: git@XXXX:SimDependency.git, Base path: , 
Supports changesets: False
>>> Making HTTP GET request to https://codereview.risc.anl.gov/api/
>>> Running: git rev-parse refs/heads/master
>>> Running: git merge-base 2a2dfe98f87440f7a76e2cb0ef31f99f52ef2188 
origin/master
>>> Running: git rev-parse cbad9b1b2eb389268abee70e58121e4650da3bf9
>>> Running: git status --porcelain --untracked-files=no
WARNING: Your working directory is not clean. Any changes which have not 
been committed to a branch will not be included in your review request.
>>> Running: git rev-parse --git-dir
>>> Running: git version
>>> Running: git -c core.quotepath=false -c diff.noprefix=false diff 
--no-color --full-index --ignore-submodules -M --no-ext-diff 
cbad9b1b2eb389268abee70e58121e4650da3bf9..2a2dfe98f87440f7a76e2cb0ef31f99f52ef2188
>>> Making HTTP GET request to 
https://codereview.risc.anl.gov/api/validation/diffs/
>>> Cached response for HTTP GET 
https://codereview.risc.anl.gov/api/validation/diffs/ expired and was 
modified
>>> Making HTTP POST request to 
https://codereview.risc.anl.gov/api/validation/diffs/
>>> Got API Error 224 (HTTP code 400): fatal: Not a git repository: 'None'

>>> Error data: {u'stat': u'fail', u'err': {u'msg': u"fatal: Not a git 
repository: 'None'\n", u'code': 224}}
Traceback (most recent call last):
  File "/usr/local/bin/rbt", line 11, in <module>
    sys.exit(main())
  File "/usr/local/lib/python2.7/dist-packages/rbtools/commands/main.py", 
line 133, in main
    command.run_from_argv([RB_MAIN, command_name] + args)
  File 
"/usr/local/lib/python2.7/dist-packages/rbtools/commands/__init__.py", line 
629, in run_from_argv
    exit_code = self.main(*args) or 0
  File "/usr/local/lib/python2.7/dist-packages/rbtools/commands/post.py", 
line 756, in main
    (msg_prefix, e))
rbtools.commands.CommandError: Error validating diff

fatal: Not a git repository: 'None'
 (HTTP 400, API Error 224)

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to