Just some additional thoughts. 

How does reviewboard talk to GitLab when displaying the diff? If there is 
no cache in reviewboard, then it's definitely something with GitLab and git 
cache. I remember this happened before when switching repos. 

On Friday, June 10, 2016 at 12:17:22 PM UTC+8, Yang Yu wrote:
> Hi there,
> So, we originally installed RB and GitLab on our own hosts and access them 
> through IP. Yesterday, we start to use domain names instead of IPs.
> 1. The GitLab repo addr changed from 111.111.*/repo to domain.com/repo
> 2. I changed the repo settings in reviewboard to point to the new domain:  
> domain.com/repo
> 3. I changed the .reviewboardrc to point the RB url to new domain: 
> rb.domain.com
> Then I found some diffs are having the "the patch didn't apply cleanly" 
> issue. Then I tried to test with a new diff (use the rbt post to generate), 
> if it's a new file to the repo, then it will be fine. If it's a 
> modification on an existing file, then it will have this issue. 
> I tried to flush the memcached with "flush_all" but it didn't work. I 
> looked at the .rej and it looks fine to me. However, the -new file is just 
> gitblob, which confuses me.
> The problem diffs are attached. I'm not quite sure how rb works. Where 
> should I go to look into next?
> Best regards,
> Yang

Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to