On Aug 14, 2016, at 19:55, Christian Hammond <christ...@beanbaginc.com> wrote:

> This looks like a MyISAM vs. InnoDB table format issue. You'll need to either 
> make sure all your tables are converted to InnoDB (you can replace "MyISAM" 
> with "InnoDB" in the database dump when you go to load it back in), or 
> configure MySQL to use MyISAM by default (though we recommend InnoDB).
> You'll need to fix things up and retry the upgrade from the backup.

Yup, that was it.  I took another database dump, used sed to change all 
instances of “MyISAM” to “InnoDB”, and re-imported the database dump.  This 
time the “rb-site upgrade” completed successfully (see log output at the end of 
this message). The web server appears to be configured properly as I can access 
the site and look at all the existing reviews.  However, when I try to log into 
the site, I get the following error:
Something broke! (Error 500)

It appears something broke when you tried to go to here. This is either a bug 
in Review Board or a server configuration error. Please report this to your 

We are authenticating against our corporate AD servers, and this works fine on 
the existing (CentOS 6 and RB V1.7.27) ReviewBoard instance.  It’s only on the 
new instance (CentOS 7 and RB V2.5.6.1) that I get this issue.  I must have 
missed a configuration setting somewhere.  Any ideas what that might be or what 
log files I should be examining to figure out where the problem is?


Output from “rb-site upgrade”:   

Rebuilding directory structure
Updating database. This may take a while.

The log output below, including warnings and errors,
can be ignored unless upgrade fails.

------------------ <begin log output> ------------------
Creating tables ...
Creating table accounts_trophy
Creating table attachments_fileattachmenthistory
Creating table diffviewer_rawfilediffdata
Creating table notifications_webhooktarget_repositories
Creating table notifications_webhooktarget
Creating table webapi_webapitoken
Upgrading Review Board from 1.7.27 to
There are unapplied evolutions for auth.
There are unapplied evolutions for contenttypes.
There are unapplied evolutions for accounts.
There are unapplied evolutions for attachments.
There are unapplied evolutions for changedescs.
There are unapplied evolutions for diffviewer.
There are unapplied evolutions for hostingsvcs.
There are unapplied evolutions for notifications.
There are unapplied evolutions for reviews.
There are unapplied evolutions for scmtools.
There are unapplied evolutions for webapi.
Adding baseline version for new models
Evolutions in webapi baseline: webapitoken_jsonfield_null
Evolutions in notifications baseline: webhooktarget_extra_state, 
Project signature has changed - an evolution is required
Installing custom SQL ...
Installing indexes ...
Installed 0 object(s) from 0 fixture(s)
Evolution successful.
------------------- <end log output> -------------------

Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to