I'm attempting to create review. I've done it before successfully when I 
was using a different server that was more up to date.

Here's code that causes the issue I'm experiencing. The client object is 
correctly authenticated user who has access to the review in question.

root = client.get_root()
request = root.get_review_request(review_request_id=162910)
print request.get_reviews().create()


Here's the stack trace. 
Traceback (most recent call last):
  File "/home/zbrown/pycharm-community-2016.2.2/helpers/pydev/pydevd.py", 
line 1580, in <module>
    globals = debugger.run(setup['file'], None, None, is_module)
  File "/home/zbrown/pycharm-community-2016.2.2/helpers/pydev/pydevd.py", 
line 964, in run
    pydev_imports.execfile(file, globals, locals)  # execute the script
  File "/home/zbrown/techWeek/reviewboardbots/responseagent.py", line 31, 
in <module>
    print request.get_reviews().create()
  File 
"/home/zbrown/.local/lib/python2.7/site-packages/rbtools/api/resource.py", 
line 137, in <lambda>
    meth(resource, **kwargs)))
  File 
"/home/zbrown/.local/lib/python2.7/site-packages/rbtools/api/decorators.py", 
line 27, in request_method
    *args, **kwargs)
  File 
"/home/zbrown/.local/lib/python2.7/site-packages/rbtools/api/transport/sync.py",
 
line 75, in execute_request_method
    return self._execute_request(request)
  File 
"/home/zbrown/.local/lib/python2.7/site-packages/rbtools/api/transport/sync.py",
 
line 84, in _execute_request
    rsp = self.server.make_request(request)
  File 
"/home/zbrown/.local/lib/python2.7/site-packages/rbtools/api/request.py", 
line 587, in make_request
    self.process_error(e.code, e.read())
  File 
"/home/zbrown/.local/lib/python2.7/site-packages/rbtools/api/request.py", 
line 563, in process_error
    raise APIError(http_status, None, None, data)
rbtools.api.errors.APIError: HTTP 500

On Wednesday, November 30, 2016 at 6:46:36 PM UTC-6, Christian Hammond 
wrote:
>
> Hi Zach,
>
> RBTools is supposed to work with Review Board 1.7.x. Can you show me the 
> problems you're hitting, along with a debug log?
>
> Christian
>
> -- 
> Christian Hammond
> President/CEO of Beanbag <https://www.beanbaginc.com/>
> Makers of Review Board <https://www.reviewboard.org/>
>
> On Wed, Nov 30, 2016 at 3:57 PM, Zach Brown <brownz...@gmail.com 
> <javascript:>> wrote:
>
>>
>> I'm working with a a Review Board v1.7.27, which is out of date I know, 
>> but I can't do anything about that. 
>> My issue is I'm trying to use RBTools and I'm running into some issues I 
>> suspect are compatibility issues.
>> Is there documentation somewhere about which version of RBTools to use 
>> for a certain version of Review Board?
>>
>> -- 
>> Supercharge your Review Board with Power Pack: 
>> https://www.reviewboard.org/powerpack/
>> Want us to host Review Board for you? Check out RBCommons: 
>> https://rbcommons.com/
>> Happy user? Let us know! https://www.reviewboard.org/users/
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard...@googlegroups.com <javascript:>.
>> For more options, visit https://groups.google.com/d/optout.
>>
>
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to