-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44663/
-----------------------------------------------------------

(Updated March 11, 2016, 5:36 p.m.)


Review request for Ambari, Alejandro Fernandez, Jonathan Hurley, Nate Cole, and 
Vitalyi Brodetskyi.


Changes
-------

Minor fixes


Bugs: AMBARI-15374
    https://issues.apache.org/jira/browse/AMBARI-15374


Repository: ambari


Description
-------

Before beginning an upgrade, there should be a pre-upgrade check which ensures 
that all known, versionable components are reporting the same version. If any 
host component is reporting a version which does not match the current 
repository version, then a warning should be produced. The warning should 
provide information on the failed components, the expected version, and the 
version they are reporting.

Note that this is only for Ambari 2.2.x; Ambari 2.4.0 uses a new workflow for 
how versions are recorded and stored during upgrade and does not need this.

There are two ways to go about this:
- Compare each service component host version to that of the {{CURRENT}} 
{{repo_version}}. However, there could be cases where the {{repo_version}} has 
not been calculated yet.

- Compare each service component host version to each other.


Diffs (updated)
-----

  
ambari-server/src/main/java/org/apache/ambari/server/checks/CheckDescription.java
 ba987aa 
  
ambari-server/src/main/java/org/apache/ambari/server/checks/ServiceComponentHostVersionMatchCheck.java
 PRE-CREATION 
  
ambari-server/src/main/java/org/apache/ambari/server/checks/UpgradeCheckGroup.java
 0be5be1 
  
ambari-server/src/test/java/org/apache/ambari/server/checks/ServiceComponentHostVersionMatchCheckTest.java
 PRE-CREATION 

Diff: https://reviews.apache.org/r/44663/diff/


Testing (updated)
-------

mvn clean test


Thanks,

Dmitro Lisnichenko

Reply via email to