-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45295/#review125312
-----------------------------------------------------------


Ship it!




Ship It!

- Richard Zang


On March 24, 2016, 4:32 p.m., Keta Patel wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45295/
> -----------------------------------------------------------
> 
> (Updated March 24, 2016, 4:32 p.m.)
> 
> 
> Review request for Ambari, Di Li, Jaimin Jetly, and Richard Zang.
> 
> 
> Bugs: AMBARI-15547
>     https://issues.apache.org/jira/browse/AMBARI-15547
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Under the List view of Roles, the name of Users with special characters, like 
> '@', are displayed with URI encoding. (please see attachment "names with URI 
> encoding.tiff" on Jira)
> The names should be displayed without any encoding.
> 
> 
> Diffs
> -----
> 
>   
> ambari-admin/src/main/resources/ui/admin-web/app/views/clusters/userAccessList.html
>  656425b 
> 
> Diff: https://reviews.apache.org/r/45295/diff/
> 
> 
> Testing
> -------
> 
> The fix for this issue is to replace the displayed name with the correct name 
> attribute, which is not URI encoded. This attribute is already present in the 
> User's object.
> The attachment "names with No URI encoding.tiff" shows the corrected User 
> names.
> 
> TEST:
> Since the change is in html file, I couldn't write a test cases for it.
> But the UI shows the changes in the User's name in the List view of Roles as 
> seen in attachment "names with No URI encoding.tiff" on the Jira.
> 
> Ambari-Web tests (orginal):
>   24689 tests complete (28 seconds)
>   145 tests pending
> 
> Ambari-Web tests (after fix):
>   24689 tests complete (27 seconds)
>   145 tests pending
> 
> 
> Thanks,
> 
> Keta Patel
> 
>

Reply via email to