This is an automatically generated e-mail. To reply, visit:

Review request for Ambari, Nate Cole, Richard Zang, and Srimanth Gunturi.

Bugs: AMBARI-16674

Repository: ambari


1) During install wizard, choose a base stack version For example: HDP-2.3
2) Proceed with this and on review page, click on deploy button

This results in an API call failure and cluster deployment does not happen.

The reason for this issue is that UI instead of using VersionDefinition ID 
generated by the ambari-server, creates and uses its own ID which is incorrect 
in case of base stack version

#Apart from addressing the bug, patch does following:#
1) Asks for VersionDefinition/stack_default attribute from the API
2) Changes the mock data to include the latest response given by he API


  ambari-web/app/assets/data/wizard/stack/HDP_version_definitions.json fde11e2 
  ambari-web/app/mappers/stack_mapper.js f9400c4 
  ambari-web/app/utils/ajax/ajax.js 866c454 
  ambari-web/test/mappers/stack_mapper_test.js 37138ee 

Diff: https://reviews.apache.org/r/47384/diff/


Verified that the patch resolves the issue manually on a cluster
Verified that all ambari-web tests passes successfully with the patch:

  27802 tests complete (29 seconds)
  154 tests pending


Jaimin Jetly

Reply via email to