-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/48281/
-----------------------------------------------------------

Review request for Ambari and Vitalyi Brodetskyi.


Bugs: AMBARI-17061
    https://issues.apache.org/jira/browse/AMBARI-17061


Repository: ambari


Description
-------

this issue I faced some 5-6 days ago , I was not able to reproduce the same.  
Again i am facing the same issue, incident is as follows:  
1) ambari-agent heartbeat lost  
2) checked the ambari-agent logs couldn't find any valid reason  
3) so restarted the ambari-agent

    
    
    
    [root@ds-xa-test-1-re-1 bin]# ambari-agent start
    Verifying Python version compatibility...
    Using python  /usr/bin/python
    Checking for previously running Ambari Agent...
    Starting ambari-agent
    Verifying ambari-agent process status...
    Ambari Agent successfully started
    Agent PID at: /var/run/ambari-agent/ambari-agent.pid
    Agent out at: /var/log/ambari-agent/ambari-agent.out
    Agent log at: /var/log/ambari-agent/ambari-agent.log
    

**it says ambari-agent successfull started but it does not start actually and 
throws unsupported locale type exception in agent.out**

following is the exception in ambari-agent.out

    
    
    
      File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 54, in 
<module>
        locale.setlocale(locale.LC_ALL, '')
      File "/usr/lib64/python2.6/locale.py", line 513, in setlocale
        return _setlocale(category, locale)
    locale.Error: unsupported locale setting
    ^[[?1034h
    

I checked the locale

    
    
    
    [root@ds-xa-test-1-re-1 bin]# locale
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=en_US.UTF-8
    LC_CTYPE=UTF-8
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    

since LC_ALL was set to empty so set the export LC_ALL=C

then restarted the ranger and it was successful.

again facing the same issue:


build detail:  
ambari-agent-2.4.0.0-625.x86_64


Diffs
-----

  ambari-agent/src/main/python/ambari_agent/main.py 32e522d 

Diff: https://reviews.apache.org/r/48281/diff/


Testing
-------

mvn clean test


Thanks,

Andrew Onischuk

Reply via email to