-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/48288/#review136333
-----------------------------------------------------------


Fix it, then Ship it!





contrib/management-packs/microsoft-r_mpack/src/main/resources/common-services/MICROSOFT_R/8.0.0/package/scripts/microsoft_r.py
 (line 30)
<https://reviews.apache.org/r/48288/#comment201351>

    Ambari QA user should not be hardcoded since it can be changed during 
installation.


- Alejandro Fernandez


On June 6, 2016, 5:30 p.m., Balázs Bence Sári wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/48288/
> -----------------------------------------------------------
> 
> (Updated June 6, 2016, 5:30 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, Jayush Luniya, Srimanth 
> Gunturi, Sumit Gupta, and Yusaku Sako.
> 
> 
> Bugs: AMBARI-17067
>     https://issues.apache.org/jira/browse/AMBARI-17067
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Made the following changes:
> - Use Ambari Python API only
> - Use new rpm's
> - Cleaned up imports.
> - Added supported HDP versions to the mpack
> 
> 
> Diffs
> -----
> 
>   
> contrib/management-packs/microsoft-r_mpack/src/main/resources/common-services/MICROSOFT_R/8.0.0/package/scripts/microsoft_r.py
>  5b6e482 
>   contrib/management-packs/microsoft-r_mpack/src/main/resources/mpack.json 
> 17c2f54 
> 
> Diff: https://reviews.apache.org/r/48288/diff/
> 
> 
> Testing
> -------
> 
> On a a single node cluster (CentOS 6.4, Ambari 2.2 upgraded to 2.4 snapshot 
> build, HDP 2.3), did the following testing:
> - Built the management pack with mvn install
> - Installed it on the Ambari Server by running this command: ambari-server 
> install-mpack --mpack microsoft-r_mpack-1.0.0.0-SNAPSHOT.tar.gz
> - Restarted the Ambari Server
> - On the UI, chose add service and selected Microsoft R.
> - Install completed without errors. It had a warning due to missing service 
> check script (covered by another Jira ticket).
> 
> 
> Thanks,
> 
> Balázs Bence Sári
> 
>

Reply via email to