> On Aug. 3, 2016, 8:41 p.m., Alejandro Fernandez wrote:
> > ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml, 
> > line 797
> > <https://reviews.apache.org/r/50756/diff/1/?file=1461309#file1461309line797>
> >
> >     This does not look like a correct fix.
> >     
> >     EU/RU from HDP 2.3/2.4 to 2.5 is adding a new config type, 
> > sqoop-atlas-application.properties, so a downgrade must remove that new 
> > config type.
> >     
> >     As a temporary solution to get EU working, I'm ok with this, but we 
> > need a Jira to remove newly added config types on downgrade.
> 
> Dmitro Lisnichenko wrote:
>     The downgrade removes this config type. The trouble is that downgrade 
> still attempts to execute actions from pre-upgrade during downgrade. So 
> adding empty pre-downgrade section solves the issue. Also added null check 
> for sanity, but it is not strictly required for fixing this issue.
>     
>     Here is a part of our javadoc:
>     ```
>     /**
>        * Determine the list of tasks given these rules
>        * <ul>
>        *   <li>When performing an upgrade, only use upgrade tasks</li>
>        *   <li>When performing a downgrade, use the downgrade tasks if they 
> are defined</li>
>        *   <li>When performing a downgrade, but no downgrade tasks exist, 
> reuse the upgrade tasks</li>
>        * </ul>
>        * @param context     the upgrade context
>        * @param preTasks    {@code true} if loading pre-upgrade or 
> pre-downgrade
>        * @param pc          the processing component holding task definitions
>        * @return A collection, potentially empty, of the tasks to run, which 
> may contain either
>        * pre or post tasks if they exist, and the order depends on whether 
> it's an upgrade or downgrade.
>        */
>       protected List<Task> resolveTasks(final UpgradeContext context, boolean 
> preTasks, ProcessingComponent pc) {
>     ```
> 
> Alejandro Fernandez wrote:
>     So why does a downgrade read elements from a pre-upgrade?
>     I'm ok with this going in for now, but we should create a Jira so that we 
> don't have to annotate this in the future.

That was designed as a convenience feature (so you we don't have to duplicate 
tasks in pre-downgrade section). But I'll open a jira for 2.5 to get some 
resolution on that.


- Dmitro


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/50756/#review144629
-----------------------------------------------------------


On Aug. 3, 2016, 7:44 p.m., Dmitro Lisnichenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/50756/
> -----------------------------------------------------------
> 
> (Updated Aug. 3, 2016, 7:44 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, Jonathan Hurley, and Nate 
> Cole.
> 
> 
> Bugs: AMBARI-18008
>     https://issues.apache.org/jira/browse/AMBARI-18008
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> RU Downgrade failure while downgrading from 2.5 to 2.3. Downgrade failed at 
> the step
> ' Client Components' ----> ' Updating configuration 
> sqoop-atlas-application.properties'.
> 
> 
> 1) Install HDP-2.3.2.0-2950 with ambari-server-2.1.2-377
> 2) upgrade ambari to 2.4.0.0-1054
> 3) Start stack upgrade to erie.
> 4) Before finalize step, start the downgrade.
> The downgrade is failing at above mentioned step.
> 
> {code}
> 02 Aug 2016 05:27:58,527  WARN [Server Action Executor Worker 4525] 
> ServerActionExecutor:497 - Task #4525 failed to complete execution due to 
> thrown exception: java.lang.NullPointerException:null
> java.lang.NullPointerException
> at 
> org.apache.ambari.server.serveraction.upgrades.ConfigureAction.execute(ConfigureAction.java:239)
> at 
> org.apache.ambari.server.serveraction.ServerActionExecutor$Worker.execute(ServerActionExecutor.java:555)
> at 
> org.apache.ambari.server.serveraction.ServerActionExecutor$Worker.run(ServerActionExecutor.java:492)
> at java.lang.Thread.run(Thread.java:745){code}
> 
> 
> Diffs
> -----
> 
>   
> ambari-server/src/main/java/org/apache/ambari/server/serveraction/upgrades/ConfigureAction.java
>  ab6614d 
>   ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/upgrade-2.5.xml 
> 6390f1f 
>   ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/upgrade-2.5.xml 
> e7bf162 
> 
> Diff: https://reviews.apache.org/r/50756/diff/
> 
> 
> Testing
> -------
> 
> on live cluster
> 
> 
> Thanks,
> 
> Dmitro Lisnichenko
> 
>

Reply via email to