-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36436/#review91749
-----------------------------------------------------------



src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java 
(line 169)
<https://reviews.apache.org/r/36436/#comment145378>

    For better readability, how about `max_update_instance_failures`?



src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java 
(line 171)
<https://reviews.apache.org/r/36436/#comment145377>

    s/scheduler datastore/storage/



src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java 
(line 173)
<https://reviews.apache.org/r/36436/#comment145375>

    Unfortunately, this will not work as you expect and derive from the value 
of `-max_tasks_per_job`.  This will always capture the default value (4000) 
since it is evaluated before the arg is populated.  In fact, this would cause a 
failure if `-max_tasks_per_job` was set on the command line, since args prevent 
setting a value after it has been read.
    
    The best way i can see to accomplish this while maintaining the 
relationship is to extract constants:
    ```
    private static final int DEFAULT_MAX_TASKS_PER_JOB = 4000;
    private static final int DEFAULT_MAX_INSTANCE_UPDATE_EVENT_FAILURES =
        DEFAULT_MAX_TASKS_PER_JOB * 5;
    ```
    
    There isn't a clean way to have this multiplier effect that Just Works, so 
i suggest you just set it to 20000 and leave a comment near `MAX_TASKS_PER_JOB` 
suggesting that this arg be changed if the default is changed there.



src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java 
(line 1123)
<https://reviews.apache.org/r/36436/#comment145376>

    This first part can be ommitted, since it's effectively covered by 
`MAX_TASKS_PER_JOB`.


- Bill Farner


On July 15, 2015, 12:30 a.m., Joe Smith wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36436/
> -----------------------------------------------------------
> 
> (Updated July 15, 2015, 12:30 a.m.)
> 
> 
> Review request for Aurora and Bill Farner.
> 
> 
> Bugs: AURORA-1096
>     https://issues.apache.org/jira/browse/AURORA-1096
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Prevent job updates from allowing unbounded instance events
> 
> 
> Diffs
> -----
> 
>   
> src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java
>  dc0cd2d71d11b8157154f7b63a14f0282dee09f1 
>   
> src/test/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterfaceTest.java
>  d28baba7618ebb194a61455971786aef46abd8eb 
> 
> Diff: https://reviews.apache.org/r/36436/diff/
> 
> 
> Testing
> -------
> 
> `./gradlew build -Pq`
> 
> 
> Thanks,
> 
> Joe Smith
> 
>

Reply via email to