> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/cli/jobs.py, line 114
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238869#file1238869line114>
> >
> >     I'm not sure what the current guiding philosophy in the client is, but 
> > I'd be more comfortable with an `else: raise ValueError(...)` than a silent 
> > non-wait.
> 
> John Sirois wrote:
>     I guess a non-wait makes ~sense for PENDING since any job starts in this 
> state instantaneously, so in some sense the state is always acheived - but 
> that's pretty loose.  I might actually mean wait for a currently running task 
> to go back into PENDING state - which would not be satisfied by a no-wait 
> no-op.

This is the current behavior of the `aurora job create` and I think we should 
consistently apply it for the similar `aurora job add` command behavior. Having 
a raising `else` block will not work as you mentioned above due to all tasks 
being in a PENDING state on creation as default state.
> I might actually mean wait for a currently running task to go back into 
> PENDING state - which would not be satisfied by a no-wait no-op.

I am not sure I understand this comment.


> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/cli/options.py, line 279
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238870#file1238870line279>
> >
> >     The parens around the help string aren't needed to capture the 
> > line-break ws adjacent concat since there are outer parens from 
> > CommandOption(...) - not sure of the style conventions; however, other 
> > CommandOptions in this file have multiline help w/o the extra parens.

Carry over from the jobs.py where this option was originally defined. Dropped.


> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/cli/jobs.py, line 100
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238869#file1238869line100>
> >
> >     s/CREATE_INSTANCE_WAIT_OPTION/ADD_INSTANCE_WAIT_OPTION/

Good catch. Renaming leftover.


> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/cli/context.py, line 201
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238868#file1238868line201>
> >
> >     Prefer `:type list of int` - better for humans _and_ intellij - which 
> > is mart enough to know what to do with the parameterization in inspections.

Done.


> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/cli/context.py, line 195
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238868#file1238868line195>
> >
> >     This is a lie as is the method name, this returns a set of int and not 
> > a list of ScheduledTask.  Definitely update the doc but possibly also the 
> > method name to `get_active_instance_ids_or_raise`.

It's not actualy a lie. We use `instances` in many other places in client (e.g. 
jobs.py, options.py, JobMonitor etc.) with the meaning of `instance_ids`. We 
use `tasks` when we mean `ScheduledTask`. I prefer to keep this convention as 
more concise.


> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/cli/context.py, line 194
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238868#file1238868line194>
> >
> >     Along the same lines as the rec below, consider 
> > s/instances/instance_ids/ for clarity.

Keeping `instances` as a more prevalent convention as described below.


> On Feb. 10, 2016, 3:57 p.m., John Sirois wrote:
> > src/main/python/apache/aurora/client/api/__init__.py, line 105
> > <https://reviews.apache.org/r/43373/diff/2/?file=1238867#file1238867line105>
> >
> >     Instead of 'with a task config of instance 2.', 'with the task config 
> > of instance 2.' or, better I think, 'using the task config of instance 2.'

Taken your last suggestion.


- Maxim


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43373/#review118665
-----------------------------------------------------------


On Feb. 9, 2016, 10:04 p.m., Maxim Khutornenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43373/
> -----------------------------------------------------------
> 
> (Updated Feb. 9, 2016, 10:04 p.m.)
> 
> 
> Review request for Aurora, John Sirois and Bill Farner.
> 
> 
> Bugs: AURORA-1258
>     https://issues.apache.org/jira/browse/AURORA-1258
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Taking advantage of the refactored addInstances RPC to add a 'scale out' 
> client command.
> 
> The mitigation of .aurora config file `instances` value mismatch is currently 
> discussed at http://markmail.org/message/5ekpapmxr4vxxcd5 and will be 
> addressed separately.
> 
> 
> Diffs
> -----
> 
>   src/main/python/apache/aurora/client/api/__init__.py 
> 63bd649377816c72ef2453d9abb7363637a91680 
>   src/main/python/apache/aurora/client/cli/context.py 
> 24a37ec60a8845b4816d292c49fed814ba0a5854 
>   src/main/python/apache/aurora/client/cli/jobs.py 
> deba3a9026384e5bd436e611ab5b5ae3afc1cfcc 
>   src/main/python/apache/aurora/client/cli/options.py 
> 226397865e54cf4c0a59ecb91b93ddc10967edf7 
>   src/main/python/apache/aurora/client/hooks/hooked_api.py 
> 185e57d08aa13b687529fefd7c356f3d50c6af33 
>   src/test/python/apache/aurora/api_util.py 
> 9d44b884e5e67506acaaecda1d9ff02a80cf1567 
>   src/test/python/apache/aurora/client/api/test_api.py 
> 1f041f42fcd5ee5d147afacd9c8f83aa3129fe47 
>   src/test/python/apache/aurora/client/cli/test_add.py PRE-CREATION 
>   src/test/python/apache/aurora/client/cli/test_options.py 
> 21d5888c0a87e07a385159de0b56420086666d9d 
>   src/test/python/apache/aurora/client/hooks/test_hooked_api.py 
> 67517a23535e3f535c3114193a5ae06bf4326515 
>   src/test/python/apache/aurora/client/hooks/test_non_hooked_api.py 
> f4b771bc968143845772a0149a943c97c5aaf963 
> 
> Diff: https://reviews.apache.org/r/43373/diff/
> 
> 
> Testing
> -------
> 
> local and manual tests in vagrant
> 
> 
> Thanks,
> 
> Maxim Khutornenko
> 
>

Reply via email to