-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43936/#review122606
-----------------------------------------------------------



David - I'm an rpm creating noob so please bear with some basic questions that 
follow:

Currently we use 
[build-artifact.sh](https://github.com/apache/aurora-packaging/blob/master/build-artifact.sh)
 which uses this 
[build.sh](https://github.com/apache/aurora-packaging/blob/master/builder/rpm/centos-7/build.sh)
 to build rpms.
Via that method of build it seems `Source0` does not come into play.  The 
`./build-artifact.sh` takes a source tarball argument that I'm guessing gets 
used by `build.sh` in a way I don't fully grok to effect this override of 
`Source0`.  I suspect you know all this, but hoping for a sanity check.

Even if the above is correct, your fix seems correct to me for those who might 
use these rpm specs manually and not just use the `./build-artifact.sh` script 
- so it can't hurt.  Do you do this?

- John Sirois


On March 8, 2016, 3:08 p.m., David Keijser wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43936/
> -----------------------------------------------------------
> 
> (Updated March 8, 2016, 3:08 p.m.)
> 
> 
> Review request for Aurora, Jake Farrell and John Sirois.
> 
> 
> Repository: aurora-packaging
> 
> 
> Description
> -------
> 
> Correct url for source0
> 
> Trying to build aurora by running spectool and then rpmbuild fails because 
> the url used does not match the release tags on github.
> 
> 
> Diffs
> -----
> 
>   specs/rpm/aurora.spec 291226da27285bf9f7c225ba4fd337691c6e8181 
> 
> Diff: https://reviews.apache.org/r/43936/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> David Keijser
> 
>

Reply via email to