> On July 10, 2016, 7:01 p.m., Aurora ReviewBot wrote:
> > Master (528198e) is red with this patch.
> >   ./build-support/jenkins/build.sh
> > 
> > virtualenv-15.0.2/virtualenv_embedded/activate_this.py
> > virtualenv-15.0.2/virtualenv_embedded/deactivate.bat
> > virtualenv-15.0.2/virtualenv_embedded/distutils-init.py
> > virtualenv-15.0.2/virtualenv_embedded/distutils.cfg
> > virtualenv-15.0.2/virtualenv_embedded/python-config
> > virtualenv-15.0.2/virtualenv_embedded/site.py
> > virtualenv-15.0.2/virtualenv_support/
> > virtualenv-15.0.2/virtualenv_support/__init__.py
> > virtualenv-15.0.2/virtualenv_support/argparse-1.4.0-py2.py3-none-any.whl
> > virtualenv-15.0.2/virtualenv_support/pip-8.1.2-py2.py3-none-any.whl
> > virtualenv-15.0.2/virtualenv_support/setuptools-21.2.1-py2.py3-none-any.whl
> > virtualenv-15.0.2/virtualenv_support/wheel-0.29.0-py2.py3-none-any.whl
> > + touch virtualenv-15.0.2/BOOTSTRAPPED
> > + popd
> > /home/jenkins/jenkins-slave/workspace/AuroraBot
> > + exec /usr/bin/python2.7 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/virtualenv-15.0.2/virtualenv.py
> >  --no-download 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/python/isort.venv
> > New python executable in 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/python/isort.venv/bin/python2.7
> > Also creating executable in 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/python/isort.venv/bin/python
> > Installing setuptools, pip, wheel...done.
> > Collecting isort==4.0.0
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/python/isort.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:318:
> >  SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject 
> > Name Indication) extension to TLS is not available on this platform. This 
> > may cause the server to present an incorrect TLS certificate, which can 
> > cause validation failures. You can upgrade to a newer version of Python to 
> > solve this. For more information, see 
> > https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
> >   SNIMissingWarning
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/python/isort.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122:
> >  InsecurePlatformWarning: A true SSLContext object is not available. This 
> > prevents urllib3 from configuring SSL appropriately and may cause certain 
> > SSL connections to fail. You can upgrade to a newer version of Python to 
> > solve this. For more information, see 
> > https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
> >   InsecurePlatformWarning
> >   Downloading isort-4.0.0-py2.py3-none-any.whl
> > Installing collected packages: isort
> > Successfully installed isort-4.0.0
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/build-support/python/isort.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:122:
> >  InsecurePlatformWarning: A true SSLContext object is not available. This 
> > prevents urllib3 from configuring SSL appropriately and may cause certain 
> > SSL connections to fail. You can upgrade to a newer version of Python to 
> > solve this. For more information, see 
> > https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
> >   InsecurePlatformWarning
> > + ./pants test.pytest 
> > --junit-xml-dir=/home/jenkins/jenkins-slave/workspace/AuroraBot/dist/test-results
> >  src/main/python:: src/test/python:: -- -v
> >   % Total    % Received % Xferd  Average Speed   Time    Time     Time  
> > Current
> >                                  Dload  Upload   Total   Spent    Left  
> > Speed
> > 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   281  100   281    0     0   5374      0 --:--:-- --:--:-- --:--:--  5403
> > 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
> > 
100 1802k  100 1802k    0     0  6195k      0 --:--:-- --:--:-- --:--:-- 6195k
> > New python executable in 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/bootstrap-Linux-x86_64/pants.udtNpF/install/bin/python2.7
> > Also creating executable in 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/bootstrap-Linux-x86_64/pants.udtNpF/install/bin/python
> > Installing setuptools, pip, wheel...done.
> > ./pants: 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/bootstrap-Linux-x86_64/pants.udtNpF/install/bin/pip:
> >  
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/boot:
> >  bad interpreter: No such file or directory
> > ./pants: line 96: 
> > /home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/bootstrap-Linux-x86_64/1.1.0-pre6/bin/pants:
> >  No such file or directory
> > 
> > 
> > I will refresh this build result if you post a review containing 
> > "@ReviewBot retry"

That build failed due to:

```
./pants: 
/home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/bootstrap-Linux-x86_64/pants.udtNpF/install/bin/pip:
 /home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/boot: 
bad interpreter: No such file or directory
./pants: line 96: 
/home/jenkins/jenkins-slave/workspace/AuroraBot/.home/.cache/pants/setup/bootstrap-Linux-x86_64/1.1.0-pre6/bin/pants:
 No such file or directory
```

I believe that the error here is that our paths are too long. There is an 
obscure limitation in the linux kernel that shebang lines cannot be longer than 
127 characters. However, once you have a virtualenv in a deeply nested 
directory structure that can happen easily.


- Stephan


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/49868/#review141617
-----------------------------------------------------------


On July 10, 2016, 6:49 p.m., Stephan Erb wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/49868/
> -----------------------------------------------------------
> 
> (Updated July 10, 2016, 6:49 p.m.)
> 
> 
> Review request for Aurora and John Sirois.
> 
> 
> Bugs: AURORA-1717
>     https://issues.apache.org/jira/browse/AURORA-1717
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Update virtualenv to 15.0.2. This includes updates to `pip==8.1.2`, 
> `setuptools==21.2.1`, and `wheel==0.29.0`. Full changelog: 
> https://virtualenv.pypa.io/en/stable/changes/
> 
> Additional changes to our scripts:
> 
> * abort the pants bootstrapping script if an error is encountered
> * switch to download URLs that are working for the latest virtualenv version
> * disable the recently added auto-updating of pip and setuptools so that we 
> gain a reproducable build environment
> 
> 
> Diffs
> -----
> 
>   build-support/virtualenv 03c14323e14d2a3923e080efc947107b9b8a3a16 
>   pants a11588a02d9b471b600a5095476caa5ae8eb8161 
> 
> Diff: https://reviews.apache.org/r/49868/diff/
> 
> 
> Testing
> -------
> 
> rm -rf ~/.cache/pants/
> git clean -fxd
> ./pants test.pytest src/{main,test}/python::
> 
> 
> Thanks,
> 
> Stephan Erb
> 
>

Reply via email to