-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/20735/#review41531
-----------------------------------------------------------


This is a no-op for the APIs we use in aurora.  It is consumed by client v1 and 
v2 for 'getVersion' and by executor_vars to extract executor versions from 
PEX-INFO.  The change from 0.2.0 to 0.3.1 was the only API backwards 
incompatibility for what we used, and that usage was fixed in 
ddd2329eaefa780a680ed34e1aecb9c5240f03dd.  0.3.1 and 0.5.4 brings structural 
changes to twitter.common.python (different APIs, wheel support) but those are 
going unused in the aurora repo.  (They are however being consumed by pants but 
pants can rely upon a different version than the repo.)

- Brian Wickman


On April 25, 2014, 9:06 p.m., Brian Wickman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/20735/
> -----------------------------------------------------------
> 
> (Updated April 25, 2014, 9:06 p.m.)
> 
> 
> Review request for Aurora and Kevin Sweeney.
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Upgrade aurora repo to twitter.common.python 0.5.4
> 
> 
> Diffs
> -----
> 
>   3rdparty/python/BUILD de7d93fc7d5e94db0f4bafbef3269e5df30fce6c 
> 
> Diff: https://reviews.apache.org/r/20735/diff/
> 
> 
> Testing
> -------
> 
> ./pants src/test/python:all -v
> 
> 
> Thanks,
> 
> Brian Wickman
> 
>

Reply via email to