> On Aug. 11, 2014, 9:05 p.m., Maxim Khutornenko wrote: > > src/main/java/org/apache/aurora/scheduler/updater/OneWayJobUpdater.java, > > lines 135-137 > > <https://reviews.apache.org/r/24465/diff/2-3/?file=655800#file655800line135> > > > > There is still job/instance state update mix here. What I was trying to > > propose is a set of action methods like: > > ... > > reEvaluateInstances(); > > beginUpdatingNewInstances(); > > computeJobUpdateStatus();
Took a stab at this. To be honest, i think it reduces readability, but we can revisit later if necessary. - Bill ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/24465/#review50232 ----------------------------------------------------------- On Aug. 11, 2014, 8:19 p.m., Bill Farner wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/24465/ > ----------------------------------------------------------- > > (Updated Aug. 11, 2014, 8:19 p.m.) > > > Review request for Aurora, Kevin Sweeney and Maxim Khutornenko. > > > Bugs: AURORA-613 > https://issues.apache.org/jira/browse/AURORA-613 > > > Repository: aurora > > > Description > ------- > > There are 3 levels to performing an update: > > 1. Move the job from state A to state B, roll back on failure > 2. Take a job from state A to state B > 3. Take an instance from state A to state B > > This implements level 2. I made the OneWayJobUpdater generic, which actually > simplified both implementation and testing, since it is only responsible for > relaying that state down to level 3. > > > Diffs > ----- > > > src/main/java/org/apache/aurora/scheduler/updater/InstanceStateProvider.java > PRE-CREATION > src/main/java/org/apache/aurora/scheduler/updater/InstanceUpdater.java > 7476d82e9691449fa968c5fc4c5af76837a5c9cf > src/main/java/org/apache/aurora/scheduler/updater/OneWayJobUpdater.java > PRE-CREATION > src/main/java/org/apache/aurora/scheduler/updater/StateEvaluator.java > PRE-CREATION > src/test/java/org/apache/aurora/scheduler/updater/InstanceUpdaterTest.java > dda1b73ead847e5ee9c5c7bc8be3cd8a7f59ac80 > src/test/java/org/apache/aurora/scheduler/updater/OneWayJobUpdaterTest.java > PRE-CREATION > > Diff: https://reviews.apache.org/r/24465/diff/ > > > Testing > ------- > > ./gradlew build -Pq > > OneWayJobUpdater has 100% instruction and branch coverage. > > > Thanks, > > Bill Farner > >
