-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25108/
-----------------------------------------------------------

Review request for Aurora and Brian Wickman.


Bugs: AURORA-670
    https://issues.apache.org/jira/browse/AURORA-670


Repository: aurora


Description
-------

Fix default logger in command runner.


Diffs
-----

  src/main/python/apache/aurora/client/api/command_runner.py 
58c298419387ede18e589a80609bc49d497ba760 

Diff: https://reviews.apache.org/r/25108/diff/


Testing
-------

Before:

  $ ./pants py src/main/python/apache/aurora/client/bin:aurora_client run 
devcluster/vagrant/test/http_example 'pwd'
  /home/vagrant/aurora src/main/python/apache/aurora/client/bin:aurora_client
  /home/vagrant/aurora run
  WARNING: ssh is an aurora clientv1 command which will be deprecated soon
  To run this command using clientv2, use 'aurora task run "pwd"'
  INFO] Starting new HTTP connection (1): precise64
  INFO] Starting new HTTP connection (1): precise64
  ERROR] 10

After this change:

  $ ./pants py src/main/python/apache/aurora/client/bin:aurora_client run 
devcluster/vagrant/test/http_example 'pwd'
  /home/vagrant/aurora src/main/python/apache/aurora/client/bin:aurora_client
  /home/vagrant/aurora run
  WARNING: ssh is an aurora clientv1 command which will be deprecated soon
  To run this command using clientv2, use 'aurora task run "pwd"'
  INFO] Starting new HTTP connection (1): precise64
  INFO] Starting new HTTP connection (1): precise64
    
After this change with -v:

  $ ./pants py src/main/python/apache/aurora/client/bin:aurora_client run -v 
devcluster/vagrant/test/http_example 'pwd'
  /home/vagrant/aurora src/main/python/apache/aurora/client/bin:aurora_client
  /home/vagrant/aurora run
  WARNING: ssh is an aurora clientv1 command which will be deprecated soon
  To run this command using clientv2, use 'aurora task run "pwd"'
  INFO] Starting new HTTP connection (1): precise64
  DEBUG] "POST /api HTTP/1.1" 200 None
  INFO] Starting new HTTP connection (1): precise64
  DEBUG] "POST /api HTTP/1.1" 200 None
  DEBUG] Running command: ['ssh', '-n', 'vagrant@192.168.33.7', u'cd 
/var/lib/mesos/slaves/*/frameworks/*/executors/thermos-1409163061330-vagrant-test-http_example-1-d1b0b32d-f968-42fb-b99d-214600a71a23/runs/latest/sandbox;pwd']


Thanks,

Joshua Cohen

Reply via email to