-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/28915/
-----------------------------------------------------------

(Updated Dec. 10, 2014, 9:39 p.m.)


Review request for Aurora, Kevin Sweeney and Maxim Khutornenko.


Repository: aurora


Description
-------

This is to hopefully eradicate flaked builds like the following:
```
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/commands/build.py",
 line 130, in _python_build
    debug=self._verbose)
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/python_builder.py",
 line 43, in build
    debug=debug).run()
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/test_builder.py",
 line 88, in run
    rv = self._run_tests([target], stdout, stderr)
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/test_builder.py",
 line 316, in _run_tests
    with self._test_runner(targets, stdout, stderr) as (pex, test_args):
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/test_builder.py",
 line 295, in _test_runner
    builder = chroot.dump()
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/python_chroot.py",
 line 191, in dump
    conn_timeout=self._conn_timeout)
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pants/backend/python/resolver.py",
 line 100, in resolve_multi
    platform=platform)
  File 
"/home/jenkins/jenkins-slave/workspace/Aurora/build-support/pants.venv/lib/python2.7/site-packages/pex/resolver.py",
 line 101, in resolve
    raise Unsatisfiable('Cannot satisfy requirements: %s' % 
requirement_set[requirement.key])
Unsatisfiable: Cannot satisfy requirements: 
[PythonRequirement(pystachio==0.7.2)]
```

Thanks to Kevin for providing the pointers here.


Diffs (updated)
-----

  build-support/jenkins/build.sh 40ef938929af3729d105dcd624f1b919b1868afa 

Diff: https://reviews.apache.org/r/28915/diff/


Testing
-------


Thanks,

Bill Farner

Reply via email to