-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32114/
-----------------------------------------------------------

Review request for Aurora.


Repository: aurora


Description
-------

Fix building when Vagrant is running with Windows as the Host OS

Changes included:

- update the update-sources script generation in provision-dev-cluster.sh to 
first make a local clone from the shared vagrant directory, apply local changes 
in the local repo to the local clone (in case this is the intended behaviour? 
removing this step is trivial) and finally rsync the cloned directory to the 
build directory, in order to avoid problems with git symlinks on Windows; see 
http://stackoverflow.com/questions/5917249/git-symlinks-in-windows
- update the test_end_to_end.sh script to check the build version from 
/home/vagrant/aurora/.auroraversion rather than /vagrant/.auroraversion, due to 
the same problem with git on Windows referenced above


Diffs
-----

  examples/vagrant/provision-dev-cluster.sh 
ae500436e703140065e5c16fc0e38dbe3214e69f 
  src/test/sh/org/apache/aurora/e2e/test_end_to_end.sh 
f255f2d0a390359da4f442505fc7b8b492dc06bb 

Diff: https://reviews.apache.org/r/32114/diff/


Testing
-------

- running vagrant up on a freshly cloned repo in Windows succeeds in building 
all the components, all 4 endpoints are up
- running test_end_to_end.sh after provisioning succeeds


Thanks,

Matias Lahti

Reply via email to